# Wann wird Text- und wann wird HTML-Mail verschickt

**URL:** <https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576>\
**Category:** Deutsches Forum\
**Tags:** templates-design\
**Created:** [November 30, 2009, 9:47am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576 "2009-11-30T09:47:46Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![MBa](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/m/4491bb/32.png) [@MBa](https://forum.oxid-esales.com/u/MBa)\
**Post date:** [November 30, 2009, 9:47am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/1 "2009-11-30T09:47:46Z")

</div>

Naja, der Titel sagt alles.

Ich finde irgendwie keine Info, wann die HTML-Mails und wann die Text-Mails verschickt werden.  
Lässt sich das Global oder pro User irgendwo einstellen?

---

<div class="post-metadata">

**Author:** ![simply\_because](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/s/f17d59/32.png) [@simply\_because](https://forum.oxid-esales.com/u/simply_because)\
**Post date:** [November 30, 2009, 9:58am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/2 "2009-11-30T09:58:31Z")

</div>

Die beiden Arten werden gemeinsam versendet und je nach dem, wie der Empfänger sein Mailprogramm konfiguriert hat, erhält er die HTML- oder Text-Variante oder sogar beides.

---

<div class="post-metadata">

**Author:** ![MBa](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/m/4491bb/32.png) [@MBa](https://forum.oxid-esales.com/u/MBa)\
**Post date:** [November 30, 2009, 10:00am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/3 "2009-11-30T10:00:06Z")

</div>

Aha, Danke.  
Also beides in einer Mail?

---

<div class="post-metadata">

**Author:** ![simply\_because](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/s/f17d59/32.png) [@simply\_because](https://forum.oxid-esales.com/u/simply_because)\
**Post date:** [November 30, 2009, 10:05am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/4 "2009-11-30T10:05:01Z")

</div>

Hmm, das kann ich Dir nicht 100% erklären, denke aber, das beides in einer E-Mail versendet wird.

Privat nutze ich The Bat und kann dort einstellen, ob HTML, Text oder Beides.  
Ich habe Beides eingestellt, muss aber auf Reiter klicken, um von der einen auf die andere Anzeigeart zu wechseln.

Im Feedbackmanager sehe ich, wenn eine E-Mail mal nicht zugestellt werden konnte, in einer E-Mail beide Versionen, also HTML und Text. Die Grundsätzlich einstellung im Feedbackmanager ist allerdings HTML-Anzeige.

---

<div class="post-metadata">

**Author:** ![MBa](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/m/4491bb/32.png) [@MBa](https://forum.oxid-esales.com/u/MBa)\
**Post date:** [November 30, 2009, 11:09am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/5 "2009-11-30T11:09:23Z")

</div>

Ok, danke.  
Werde dann mal die HTML-Mail leerlassen, mal schauen was passiert.

---

<div class="post-metadata">

**Author:** ![simply\_because](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/s/f17d59/32.png) [@simply\_because](https://forum.oxid-esales.com/u/simply_because)\
**Post date:** [November 30, 2009, 11:36am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/6 "2009-11-30T11:36:51Z")

</div>

Für Test’s, oder?  
Geh mal davon aus, das die meisten User E-Mails im HTML-Format erhalten, die werden dann eine leere E-Mail sehen.

---

<div class="post-metadata">

**Author:** ![MBa](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/m/4491bb/32.png) [@MBa](https://forum.oxid-esales.com/u/MBa)\
**Post date:** [November 30, 2009, 11:58am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/7 "2009-11-30T11:58:09Z")

</div>

Vielleicht für Tests…  
ich gehe davon aus, wenn kein

```auto

<html>
 <head>...</head>
 <body>...</body>
</html>

```

in der Mail steht, dass diese als Plaintext interpretiert wird.

Klar, muss ich so diverse Mailclients testen… aber warum sollten die Clients den eigentlichen Mailstandard nicht verstehen?

---

<div class="post-metadata">

**Author:** ![MBa](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/m/4491bb/32.png) [@MBa](https://forum.oxid-esales.com/u/MBa)\
**Post date:** [November 30, 2009, 4:13pm UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/8 "2009-11-30T16:13:09Z")

</div>

Ne, irgendwie stimmt das nicht.

Hatte die HTML-Mail leer und bekahm gar keine Mail mehr.

Nach einigen Nachforschungen:  
Man kann manche EMail-Clients so einstellen, dass sie HTML als Text vernünftig darstellen.

Damit ich aber trotzdem nur noch ein Template pro Mail (redundanzfrei) habe:  
HTML-Mail:

```auto

<html>
	<head>
		<title>[{ $shop->oxshops__oxordersubject->value }]</title>
		<meta http-equiv="Content-Type" content="text/html; charset=[{$charset}]">
	</head>
	<body>
		[{include file="email_%email-Template%_plain" assign='sEMail'}]
		[{$sEMail|nl2br}]
	</body>
</html>

```

… für alle, die es interessiert.

---

<div class="post-metadata">

**Author:** ![beni\_bb](https://forum.oxid-esales.com/letter_avatar_proxy/v4/letter/b/2bfe46/32.png) [@beni\_bb](https://forum.oxid-esales.com/u/beni_bb)\
**Post date:** [December 15, 2009, 10:56pm UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/9 "2009-12-15T22:56:10Z")

</div>

Mich würde die Frage auch sehr interessieren. Ich mag HTML-Mails nicht so sehr und würde lieber nur Plain-Text-Mails verschicken:

Deshalb ein Aufruf an die Moderatoren -\> Ist dies irgendwie Möglich?

PS: Da dies mein erster Post hier im Forum ist, muss ich an dieser Stelle noch ein dickes Lob an die Adresse des OXID-Teams loswerden! Ihr habt ein super Shop auf die Beine gestellt! Sauber aufgebaut, einfach erweiterbar, nicht zu komplex und dazu noch Open-Source. Als bisheriger oscommerce-User bin ich begeistert! Vielen Dank und macht weiter so! 😃

---

<div class="post-metadata">

**Author:** ![marco.steinhaeuser](https://forum.oxid-esales.com/user_avatar/forum.oxid-esales.com/marco.steinhaeuser/32/1832_2.png) [@marco.steinhaeuser](https://forum.oxid-esales.com/u/marco.steinhaeuser)\
**Post date:** [December 16, 2009, 8:13am UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/10 "2009-12-16T08:13:19Z")

</div>

Moin,

richtig Frank: Die Nachrichten werden aus dem Shop heraus als sog. Multipart Messages verschickt:

> **[Multipurpose Internet Mail Extensions](https://de.wikipedia.org/wiki/Multipurpose_Internet_Mail_Extensions)**
>
> Die Multipurpose Internet Mail Extensions (MIME) sind Erweiterungen des Internetstandards RFC 822 (seit 2008 durch RFC 5322 ersetzt), der das Datenformat von E-Mails definiert. Dieser sieht nur den American Standard Code for Information Interchange (ASCII) vor. Die MIME schaffen Kompatibilität für zusätzliche Zeichen wie Umlaute sowie für Multimedia (etwa bei Mail-Anhängen). Sie wurden in RFC 2045, RFC 2046, RFC 2047, RFC 2048 und RFC 2049 definiert. RFC 2048 wurde von der Internet Engineering Ta...

“Eine Multipart-Message enthält mehrere Bodyparts, die durch eine Grenzlinie (boundary) abgegrenzt werden.”

Da der Email-Versand ja über den phpmailer gezogen wird könnte ich mir vorstellen, dass es dort gar irgendeine Option einzustellen gibt, die regelt, ob man MIME, HTML oder nur TXT verschicken möchte.

Danke @beni_bb 🙂 Ich reich’s an die Entwicklung weiter 😉

Gruß

---

<div class="post-metadata">

**Author:** ![system](https://forum.oxid-esales.com/user_avatar/forum.oxid-esales.com/system/32/4245_2.png) [@system](https://forum.oxid-esales.com/u/system)\
**Post date:** [July 13, 2026, 7:48pm UTC](https://forum.oxid-esales.com/t/wann-wird-text-und-wann-wird-html-mail-verschickt/40576/11 "2026-07-13T19:48:16Z")

</div>


