Admin Panel and Shop Frontend Giving localhost 500 error

I am trying to migrate from oxid version 4 to oxid version 6

I am using this guide here: https://docs.oxid-esales.com/developer/en/6.0/update/eshop_from_53_to_6/index.html

Problem is in database migration. I installed oxide version 6.0 from composer and after installation i completely emptied its database. Imported my oxid 4 database and ran the two scripts:

migrate_pe_5_3_to_6_0.sql
migrate_pe_5_3_to_6_0_cleanup.sql

After that i ran the given the commands:

vendor/bin/oe-eshop-db_migrate migrations:migrate
vendor/bin/oe-eshop-db_views_generate

Now when i go to localhost and try to access my shop or its admin panel. The only thing i get is

localhost is currently unable to handle this request.
HTTP ERROR 500

and there are no error logs in EXCEPTION_LOG.txt

What should i do? What am i doing wrong here?

You can set $this->iDebug = 1; in config.inc.php (enable write access first) and see if an error is displayed, otherwise you have to get access to the apache webserver error logs.

@leofonic I set $this->iDebug = 0 to $this->iDebug = 1 and also check apache error logs.
The first error i get is this:

Fatal error: Maximum function nesting level of ‘256’ reached, aborting! in D:\UwAmp\www\oxid_pe_6_one\vendor\oxid-esales\oxideshop-ce\source\Core\NamespaceInformationProvider.php on line 76

This is a core file, i dont think i should be making changes in that. What could be wrong in that can you please guide ?

There might be an error with module configuration, you can reset module info with this SQL:

delete from oxconfig where oxvarname in ('aModulesHistory','aModuleVersions','sUtilModule','aDisabledModules','aLegacyModules','aModuleFiles','aModulePaths','aModules','aModuleTemplates');

and clear /tmp right after this sql.

1 Like

@leofonic That worked like a charm! i am now logged in to admin panel, but however i still can’t access the shop frontend. I get this error:

Warning: Smarty error: unable to read resource: "message/exception.tpl" in D:\UwAmp\www\oxid_pe_6_one\vendor\smarty\smarty\libs\Smarty.class.php on line 1100

Please know that, i am migrating from so i guess theme files maybe missing, so while i am porting theme files to oxid version 6, Let me know if its the theme files issue or something else by looking at the error mentioned.

Please bare with me as i am totally new to this oxid shop, and don’t know how to debug. Thankyou!

If you have admin access you can set the theme to “flow” in extensions, this should fix the error.

1 Like

@leofonic i ported the theme files , and i got this error:

OxidEsales\EshopCommunity\Core\Exception\SystemComponentException-OxidEsales\EshopCommunity\Core\Exception\StandardException (time: 2019-07-15 15:11:17): [0]: Function ‘getFbAppId’ does not exist or is not accessible! (OxidEsales\Eshop\Core\ViewConfig)

it maybe because facebook got removed from oxid v6, should i install it via composer ? as mentioned in the documentation ?

Yes facebook was removed, i think it’s available as an extension. There might be some other errors in theme, you can check whether it’s theme-related by switching to flow theme and see if the error disappears.

I switched to default theme which is ‘flow’ and it removed error. But however i am always redirecting back to this url:

http://localhost/oxid_pe_6_one/source/mein-konto/

Also i am getting these things below the page:

The things below the page is the debug info, to switch off set iDebug to 0 again. Redirection to mein-konto: you might have private sales activated in master settings, core settings, settings, private sales.

1 Like

Yes, private sales was enabled, i disabled that and now i am on shop homepage and i am seeing some products. And okay i’ll turn that iDebug off again that would be great. So is my database migration completed i guess?

Yes all fine!

1 Like

Thankyou for all the help :slightly_smiling_face:

2 Likes