Amazon Login (BESTIT): Login versagt (Konto konnte nicht gefunden werden)

Hallo zusammen,

wenn ich mich testweise mit meinem Amazon-Konto einloggen möchte, kommt folgende Fehlermeldung:
“Es konnte kein Konto mit dieser E-Mail-Adresse gefunden werden.”
Die Zugangsdaten habe ich bei Amazon selbst noch einmal probiert, alles in Ordnung.
Zusätzliche Fehlermeldungen erhalte ich weder im Error-Log des vHosts noch in Oxids Exception-Log

Hat jemand eine Idee, woran das liegen könnte?

Das Modul ist nicht im Sandbox-Modus.
Ich verwende Oxid CE 6.0.2 und das Amazon Modul von BESTIT in der Version 3.3.0

Vielen Dank!

Nachtrag: Laut Dokumentation* gibt es ein separates Log für das Modul unter /log/bestitamazon/
Ein ensprechendes Verzeichnis gibt es nicht. Die Rechte für den log-Ordner sind derzeit auf 775.
In den Settings für das Modul ist “Logging enabled”.
*Die Dokumentation findet sich übrigens hier:
https://bestit.atlassian.net/servicedesk/customer/portal/7/article/619118852
(Ist leider derzeit von diversen Stellen falsch verlinkt und führt sonst entweder ins Leere oder im Kreis)

Versuchst du dich vielleicht mit deinem Amazon Konto im Shop anzumelden? Also nicht über den Button “Login mit Amazon”?

Nein, es ist schon der “Login mit Amazon”-Button. Leider :slight_smile:

Das Amazon Popup geht auch entsprechend auf, wenn man auf den Button klickt?

Der Ablauf wäre ja der folgende:

  • Klick auf Login mit Amazon
  • Amazon Popup mit Login Möglichkeit
  • Login im Popup
  • Schließung des Popups
  • Automatisches Login im Shop

Im letzten Schritt kommt dann die Fehlermeldung?

Ja, das Popup-Fenster öffnet sich, der Login-Versuch findet im Fenster statt (Listenpunkte 1-3).
Die Fehlermeldung kommt allerdings schon innerhalb des Fenster über dem Eingabeformular, also ohne dass sich das Fenster zuvor schließt.

So schaut’s aus:

Update: Eine Kollegin kann sich erfolgreich einloggen.
Mit meinem Login geht’s nicht. Vertipper ausgeschlossen, ich habe E-Mail und Passwort überprüft und sogar aus derselben Quelle einkopiert, um sicher zu sein.
:thinking:

Evtl. das Händllerkonto?

Nein, ist ein anderes Konto, mein privates Amazon-Konto.

Scheint mein Einzelschicksal zu sein. Bei einem weiteren Kollegen geht’s auch.
Rätselhaft.

Bei besagtem Kollegen werden übrigens außer E-Mail, Vor- und Nachname keinerlei Adressdaten von Amazon übergeben. PLZ, Ort… fehlt alles. Aber das ist wohl ein anderes Problem…

Update: Ich konnte reproduzieren, unter welchen Bedingungen das Einloggen trotz korrekter Daten fehlschlägt.
Sobald in der Login-Maske von Oxid (also NICHT im Pop-Up-Fenster von Amazon) eine abweichende E-Mail-Adresse steht, ignoriert die Amazon-Login-Funktion die im Pop-Up-Fenster eingetragene E-Mail-Adresse und versucht das Login offenbar mit der E-Mail-Adresse aus dem Oxid-Formular.
Sobald ich das entsprechende Feld lösche oder mit der anderen E-Mail-Adresse befülle, kann ich mich auch über Amazon einloggen.
Das ist ganz klar eine Fehlfunktion, aber zumindest weiß ich jetzt, was hier passiert.

(Nun kann man natürlich fragen, warum man überhaupt mit einer anderen Adresse beginnt. In meinem Fall - geht vielleicht anderen auch so - hat der Browser einfach meine gängigen Angaben vorausgefüllt. Da es sich aber nicht um das Formular handelt, das ich beim Login (im Popup) abschicke, habe ich dessen Inhalt ignoriert.)

Update II: Nachdem ich mich einmal erfolgreich eingeloggt und danach auch aus dem Amazon-Konto wieder ausgeloggt habe, kann ich den Fehler nicht mehr reproduzieren.