Bei OXID Update von 6.1.5 auf 6.2.4 passiert mit oe-console Befehlen nichts

Ich habe einen Shop von 6.1.5 auf 6.2.4 (PHP 7.4) geupdated und möchte die Module aktualisieren.
Doch mit dem Befehl vendor/bin/oe-console oe:module:install-configuration source/module/MODUL passiert einfach nichts. Keine Antwort, keine Veränderung mit der 1.yaml. Generell liefern auch andere oe-console Befehle keine Antwort in der Konsole.
Funktioniert die nicht oder mache/verstehe ich was falsch? Ich möchte einfach nur, dass von dem Modul die metadata.php Konfiguration in die 1.yaml richtig übertragen wird.

Eigentlich geschieht das mit dem Update der yaml mit

vendor/bin/oe-console oe:oxideshop-update-component:install-all-modules

und weiteren Befehlen. Siehe…

Von 6.1.x auf 6.2.0 aktualisieren — OXID eShop 6.2 | Anwenderdokumentation (oxid-esales.com)

Aber selbst dabei passiert nichts und kommt keine Antwort.

Merge pull request #31 from vanilla-thunder/b-6.2-de · OXID-eSales/[email protected] · GitHub

Die Befehle inkl. TMP leeren habe ich schon probiert. Beim Updaten haben die Befehle auch funktioniert, nur jetzt liefern die auch keine Antwort oder Veränderung mehr. Kann es irgendetwas mit bestimmten Einstellungen zu tun haben, dass es nicht mehr funktioniert?

Schwierig. Ich hatte ein ähnliches Verhalten vor kurzem bei einem Update und einem gleichzeitigen Wechsel von CE auf PE. Was letztendlich der Haken war weiß ich nicht mehr, aber das hab ich gemacht und danach ging es wieder:

  • Lizenzkey neu eingetragen (der wurde nicht mehr korrekt erkannt)
  • compser.lock und den vendor ordner gelöscht und 'composer u --no-dev" neu laufen lassen
  • Fehler in der source/log/oxideshop.log beseitigt (nach einem Update kann es bei Modulen durchaus mal zu Inkompatibilitäten kommen, die die Ableitungskette kaputt machen)
  • Wie immer Caches gelöscht und Views neu generiert

Vielleicht hilft es dir…
Grüße,
Thorsten