Change in core files stopped working of system

Hi All,
I have installed oxid on localhost. I am astonished by the behaviour of the system. Yesterday I made some changes in some core files (put some die() function) to check some variable’s values. The files were related to product export. After checking I removed all my embeded code from files and run product export but it stopped working. It don’t show any thing on the above red bar of product export section which shows the number of exporting products during process and shows link of download after completing the process. I though that my be I have forgot to remove some code so today I have set up another project on local host because previous one is still not working due to above mentioned problem.

Now In newly generated project the product export was working. I want to understand the flow of the product export so I put a die() e 448 in the dynexportbase class (prepareExport function) to check the $heaptable variable. I checked that, then I removed the die() from the file. But after that when I run the productexport it again stopped working.

I have deleted all files in temp folder, clear cookies and sessions of browsers but nothing happen? What is this behaviour? What should I do? Is this some kind of bug? Or I have to delete some file or any thing else to get rid off this problem? I am panic of this situation


Awais Qanri

try to refresh VIEWS in Backend -> Service -> Tools

[QUOTE=Hebsacker;82681]try to refresh VIEWS in Backend -> Service -> Tools[/QUOTE]

Hi dude again thanks but I don’t find any option of VIEWS in Backend -> Service -> Tools . There is only an sql option there in tools. Nothing else.

which shop version?

[QUOTE=Hebsacker;82683]which shop version?[/QUOTE]
I am using community edition 4.5.6_40808

it must be there, check screenshot

[QUOTE=Hebsacker;82687]it must be there, check screenshot[/QUOTE]

Oh sorry that was there having name “Update DB Views now”. I done that but still the problem is there. Product export still stops as its was before

OO Solved. This was due to the wrong entry for module in core settings->modules. I was doing entry like


which is wrong.
I have written this because I saw the oxid module that was related to articles. On left side the oxarticle means it will find the oxarticle class in admin folder. So here put your own class name. I changed to above to



Due to above wrong entry my product listing and product export section went to off. This answer if for others who face the same problem