Composer only downloaded a single .json file


#1

Hi
So the site i’m working on runs on Oxid eshop CE 4.10.6 hosted in Hosteurope, and after the php update to 7.2, it stopped working (understandably). My problem is that when i ran the command in the documentation for the upgrade process, it only downloaded a single file “composer,json” in the “your_project_name” folder, which leads me to believe that something is wrong since the documentation doesn’t mention an extra step after this, it goes straight to dealing with directories and setup. Originally i had issues installing and running Composer since the server is a managed instance and i don’t have root access to everything. The only way i was able to use composer was by using “php composer.phar” instead of just “composer” otherwise i woulg get “command not found” even after it said that composer was successfully installed. Again, only way to view composer version is with “sudo php composer.phar --version”

Home directory is /is/htdocs/package_number and that’s where the composer.phar and your_project_name folder are located.


#2

there is no composer command for upgrading from 4.10 to 6. Give us at least the link to the updating manual you are refering to


#3

https://docs.oxid-esales.com/developer/en/6.0/update/eshop_from_53_to_6/files.html (step 1. points to this next link)

https://docs.oxid-esales.com/developer/en/6.0/getting_started/installation/eshop_installation.html


#4

okay, this one will install new oxid 6.
check composer output for some erros, like missing php mods or other requirements


#5

that’s what’s weird about this. I didn’t get any errors or dependency issues after the command.


#6

try this one:
composer create-project --no-dev oxid-esales/oxideshop-project my_oxid_eshop_project dev-b-6.1-ce


#7

same still…the output starts by saying that it’s installing the shop, creates the directory, loading composer repositories with package information, updating dependencies and then just stops. I’m sorry if i didn’t mention it in the post but i think i got the same result the first time i ran the command for 6.0, but i wasn’t sure since my ssh session timed out and had to reconnect so i didn’t manage to see the previous output.


#8

i would check internet for similar composer problems, since its external and widely used tool. probably there is a bug with particular version or operating system


#9

ok thank you, will check.


#10

To be honest: I get stomach aches seeing somebody playing around with composer on a live system with a PHP version that is not officially tested yet, at a hosting provider we have no contact with and who will stop PHP 7.0 support by beginning of December (this year!).

Why not simply update the shop in a dev environment and transfer it to the server afterwards?


#11

Since the site doesn’t work and i’ve already backed up the site and database, i figured there’s no problem in testing directly and i wanted to avoid using virtual machines, but i suppose you’re right and i already don’t have another choice but to follow the instructions you provided. Thanks.


#12

Wanted to test Composer in a safe environment since i’ve never worked with it before and i also wanted to see the latest eshop from a fresh start so i created a virtual machine with vmware running ubuntu, but that composer command to get the shop still only downloaded a “composer.json” file again, like it did on the server. The documented process for installing a fresh shop only has that command which makes this process confusing. Anyone got any idea what could be the problem here?

Note: i have followed the instructions on how to install composer step-by-step.


#13

This is only a wild guess: did you install composer running apt install (from ubuntu repositories) or did you really download the very latest version from getcomposer.org?


#14

Getcomposer.org… Also running “composer” in the terminal shows that it is installed and shows the version just like instructed in the composer official site


#15

Any other error message while composer run? Anything? Otherwise I wouldn’t even know where to search…


#16

no, nothing…i would’ve mentioned if there were any errors, either during composer installation or while running, it just creates the directory in the command “my_oxid_eshop_project” for example (as in main article for version 6.1) and in that directory there’s just one file…composer.json


#17

Can you post the output on your terminal after $ composer create-project …?


#18

The sixth comment of the post describes what i got. Any more details would have to wait until monday since i have the weekend off.


#19

I think I see what’s going on: I reckon it stops at $ Updating dependencies, right? Looks like composer is a damned resource-hungry beast (memory?) Give it some more server power.

I just let composer run for a new installation on my local machine. Until $ Updating dependencies it made a new folder and set up a composer.json file. Then - after it ran for a while, it started downloading /vendor/ folder and even later made the /source/ folder. So I guess it times out while running the dependency updates memory-wise…


#20

yes, it always stopped at “updating dependencies”. In my local machine i had setup the VM with 8gb of ram, so i can try increasing the memory to 10-12gb and/or a few more cpu threads. Might even explain this issue in the actual server since it’s a Webhosting package on hosteurope, (tho i have no clue about the specs). I will test this first thing on monday when i get to the office.