Composer RuntimeException beim Installieren eines Moduls

Hallo, ich versuche der Module MultiNavi zu installiert, aber bekomme dier warnung,

[RuntimeException]
The url supplied for the path (./packages/sit/*) repository does not exist

Ich mache wie der datei README sagt.

Vorbereitung der Modulinstallation


Erstellen Sie via SSH-Client eine Verbindung mit dem Server, auf dem Ihr OXID eShop liegt.
Wechseln Sie in das OXID-Projektverzeichnis, in dem sich die Datei composer.json sowie die source- und vendor-Ordner befinden.
Führen Sie dort folgende Befehle aus (bitte jede Zeile einzeln ausführen):

md vendor/zip

composer config repo.meinzip artifact ./vendor/zip

als ich Linux benutzer bin, benutze nicht der Kommando md vendor/zip' sonder mkdir vendor/zip und dann composer config repo.meinzip artifact ./vendor/zip, alles es geht gut…
dann

  1. Loggen Sie sich via FTP auf dem Server ein und kopieren Sie die ZIP-Datei (das eComStyle.de-Modul) unverändert in den Ordner vendor/zip.
  1. Erstellen Sie via SSH-Client eine Verbindung mit dem Server, auf dem Ihr OXID eShop liegt.
    Wechseln Sie in das OXID-Projektverzeichnis, in dem sich die Datei composer.json sowie die source- und vendor-Ordner befinden.
    Führen Sie dort folgenden Befehl aus:

composer require ecs/multinavi

ich mache wie sie sagen ohne probleme, die probleme bekomme mit

composer require ecs/multinavi

wenn schreibe sagt

[RuntimeException]
The url supplied for the path (./packages/sit/*) repository does not exis
t

so, in mein Projektverzeichnis, in dem sich die Datei composer.json sowie die source- und vendor-Ordner befinden. habe keine Ordner der heißt packages

In meiner Verzeichniss composer.json, an ende habe,

"repositories": {
"sit": {
  "type": "path",
  "url": "./packages/sit/*"
},
"meinzip": {
  "type": "artifact",
  "url": "./vendor/zip"
}
}

jetzt have versuche mit dem Rechten, ich habe der Verzeichiss zip der Rechten 755,

dann schreibe,

composer require ecs/multinavi

aber bekomme gleiche warnung,

[RuntimeException]
The url supplied for the path (./packages/sit/*) repository does not exist

Der packages verzeichnis gibt es nicht in der Module…

Mit composer update -W bekomme diese warnug,

The “oxid-esales/oxideshop-unified-namespace-generator” plugin was skipped because it requires a Plugin API version ("^1.1.0") that does not match your Composer installation (“2.0.0”). You may need to run composer update with the “–no-plugins” option.
The “oxid-esales/oxideshop-composer-plugin” plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation (“2.0.0”). You may need to run composer update with the “–no-plugins” option.

Problem 1
- Root composer.json requires oxid-esales/oxideshop-ide-helper ^v3.1.2 -> satisfiable by oxid-esales/oxideshop-ide-helper[v3.1.2].
- oxid-esales/oxideshop-ide-helper v3.1.2 requires composer-plugin-api ^1.1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 2
- oxid-esales/oxideshop-composer-plugin v5.0.1 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
- oxid-esales/oxideshop-metapackage-ce v6.2.2 requires oxid-esales/oxideshop-composer-plugin v5.0.1 -> satisfiable by oxid-esales/oxideshop-composer-plugin[v5.0.1].
- Root composer.json requires oxid-esales/oxideshop-metapackage-ce v6.2.2 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.2.2].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

so, die Proble ist das ich zwei Composer habe, eine in mein Root Verzeichniss von der Webserver, der andere was mit Oxid kommt…was können euch mir empfehlen und diese Probleme zu losen?

Entfern der Composer der auf meine Root Verzeichniss ist ?

Dies liest sich für mich nach einen Problem für ein anderes Modul… eins von https://www.shopmodul24.de/OXID-Module/

Fazit Deine Dateien composer.json bzw. composer.lock sind falsch bzw. invalid.

Wahrscheinlich hast Du ein anderes Modul nicht richtig installiert bzw. deinstalliert.

Danke für deine antwort!

Dies liest sich für mich nach einen Problem für ein anderes Modul… eins von

Mit composer --no-plugins an ende bekomme das,

diesen Module kann sein? sie gehört zum Pay Pal…

du weißt wie diese probleme losen kann?

das sind Überreste von dem Modul, das du vor 2 Wochen installierrt hast.

aber ich habe gelost mit composer remove sit/multifilter

mit composer --no-plugins diagnose bekomme,

du hast lediglich die Dateien gelöscht, man muss aber alle durchgeführten Änderungen rückgängig machen, d.h. auch den Eintrag in repositories in composer.json entfernen.

1 Like

Zusätzlich den repositories Eintrag entfernen. Probier mal

composer config --unset repositories.sit/multifilter

ich habe in der Datei composer.json gelost was über diese Module sprecht,

dann composer update und bekomme,

@ indianer3c

mit composer config --unset repositories.sit/multifilter bekomme,

[email protected][~/xxxxx/xxxx]# composer config --unset repositories.sit/multifilter
The “oxid-esales/oxideshop-unified-namespace-generator” plugin was skipped because it requires a Plugin API version ("^1.1.0") that does not match your Composer installation (“2.0.0”). You may need to run composer update with the “–no-plugins” option.
The “oxid-esales/oxideshop-composer-plugin” plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation (“2.0.0”). You may need to run composer update with the “–no-plugins” option.

@joseba Du hast anscheinend noch weitere Fehler in Deiner composer.json

Am besten vergleichst Deine composer.json Datei mit der composer.json die auf GitHub liegt für Deine verwendete Shopversion.

Beispiel für CE 6.2 Serie https://github.com/OXID-eSales/oxideshop_project/blob/b-6.2-ce/composer.json

1 Like

Danke!, jetzt bekomme in Composer nicht mehr dieses Warnung…

Aber schreibe composer require ecs/multinavi bekomme,

[InvalidArgumentException]
Could not find a matching version of package ecs/multinavi. Check the package spelling, your version constraint and that the package is available in a
stability which matches your minimum-stability (stable).

Bitte :slight_smile:

Ja Du musst natürlich alle Installationschritte wiederholen wahrscheinlich fehlt

Zip-Ordner bekannt machen

Composer muss mitgeteilt werden, dass er ab sofort auch im zip-Ordner nachsehen muss, ob dort ein angefordertes Package verfügbar ist.

Mit folgendem Befehl wird der zip-Ordner in die OXID-composer.json eingetragen:

composer config repo.meinzip artifact ./vendor/zip

Quelle: https://ecomstyle.de/blog/oxid6-module-2-zip-archive-mit-composer-installieren/

ich have alles von Null gemacht und bekomme gleiche Warnung,

In OXID-Projektverzeichniss

   mkdir vendor/zip
   composer config repo.meinzip artifact ./vendor/zip

Schickt der Module von mein Rechner nach Websever in verzeichniss vendor/zip

dann in OXID-Projektverzeichniss

composer require ecs/multinavi

[InvalidArgumentException]
Could not find a matching version of package ecs/multinavi. Check the package spelling, your version constraint and that the package is available in a
stability which matches your minimum-stability (stable).

Geschafft!!

Mein Fehler… ich have Erste der Archive Entpacket und dann nach dem Webserver gebracht, wenn musste OHNE Entpacket zu sein…

Zeile 45 …Loggen Sie sich via FTP auf dem Server ein und kopieren Sie die ZIP-Datei (das eComStyle.de-Modul) unverändert in den Ordner vendor/zip.

jetzt bekomme die Module…

ich bedanke mich alle euch für eure Hilfe und wünsche alle euch ein schöne neuer Jahr!

1 Like

Gerne, Dir auch ein schönes, gesundes und erfolgreiches Jahr 2021 :slight_smile: