Composer update und require funktionieren nicht; blockiert; "Your requirements could not be resolved to an installable set of packages."

Hallo liebe Oxid-Freunde,

zum composer gibt es schon etliche Beiträge aber ich habe gerade leider nicht das gefunden, was sich gesucht habe. Ich möchte ein Modul installieren und folgendes passiert:

composer require oxid-projects/extended-order-administration-module
Using version ^2.0 for oxid-projects/extended-order-administration-module
./composer.json has been updated
Running composer update oxid-projects/extended-order-administration-module
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - d3/modcfg is locked to version 6.0.0.0 and an update of this package was not requested.
    - d3/modcfg 6.0.0.0 requires php 7.3 - 8.0 -> your php version (7.2.34) does not satisfy that requirement.
  Problem 2
    - oxid-esales/testing-library is locked to version v8.0.0 and an update of this package was not requested.
    - oxid-esales/testing-library v8.0.0 requires php ^7.3 || ^8.0 -> your php version (7.2.34) does not satisfy that requirement.
  Problem 3
    - doctrine/dbal 2.12.1 requires php ^7.3 || ^8 -> your php version (7.2.34) does not satisfy that requirement.
    - oxid-esales/oxideshop-metapackage-ce v6.3.0 requires doctrine/dbal 2.12.1 -> satisfiable by doctrine/dbal[2.12.1].
    - oxid-esales/oxideshop-metapackage-ce is locked to version v6.3.0 and an update of this package was not requested.


Installation failed, reverting ./composer.json and ./composer.lock to their original content.

oder

composer update
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - doctrine/dbal 2.12.1 requires php ^7.3 || ^8 -> your php version (7.2.34) does not satisfy that requirement.
    - oxid-esales/oxideshop-metapackage-ce v6.3.0 requires doctrine/dbal 2.12.1 -> satisfiable by doctrine/dbal[2.12.1].
    - Root composer.json requires oxid-esales/oxideshop-metapackage-ce v6.3.0 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.3.0].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Hat jemand ne Ahnung, was ich falsche mache?
Was das für ein Konflikt ist?
Und wie ich das Problem lösen kann?

Danke vorab.

Es ist ein OXID 6.3.0 unter PHP 7.4 installiert

da stehts doch:

doctrine/dbal 2.12.1 requires php ^7.3 || ^8 → your php version (7.2.34) does not satisfy that requirement.

gib mal php -v in der Console ein, da kommt dann, dass du PHP 7.2.34 und nicht 7.3 hast.

konnte das Problem gelöst werden, oder sucht ihr noch nach einer Lösung?

Diese Thread ist nun mittlerweile auch schon wieder ein paar Wochen alt und ich bin erst jetzt wieder an diesem Punkt angekommen.

Also vanilla_thunder hatte recht. Ich habe mich vom drumherum der Fehlermeldung zu sehr irritieren lassen.

Konkret ist die Umgebung bei mit, dass der betreffende Shop auf einem Server bei All-Inkl läuft.
In der Verwaltungsoberfläche ist eingestellt, dass PHP 7.4 zum Einsatz kommt.
Hier auf der Kommandozeile lief aber PHP unter 7.2
ich habe mit dieser Anweisung
ln -sfv /usr/bin/php74 /usr/bin/php
einfach die PHP-Version der Kommandozeile auch auf PHP 7.4 gesetzt - danach ging es.
Hier die Doku bei All-Inkl: https://all-inkl.com/wichtig/anleitungen/kas/ssh/dateiverwaltung/aenderung-der-php-cli-version_527.html

Danke für Eure Antworten!