Dependencies update führt zu 500 internal server error

Hallo zusammen,

ich habe seit geraumer Zeit das Problem das ein composer update zu einem Internal Server Error führt.
Das Update scheint erstmal gut druchzulaufen, es werde nur abandoned packages erwähnt.
Außerdem führen Updates der Module oder des Shops zum Internal Server Error, wenn die Dependencies geupdated werden.
Irgendwer gut vertraut mit der Thematik ? Erstmal keine Errors im log odersowas.

Viele Grüße,

Habe diese Meldung gefunden:

End of script output before headers: index.php

Das hießt es muss irgendeine Konfiguration nicht kompatibel sein.
Die letzten Updates hatten alle sehr gut geklappt, deswegen bin ich irritiert warum das aufeinmal nicht mehr so gut klappt.

Das ist irgendwie alles Stochern im Dunkeln… Schau mal, was ich dazu gefunden habe:

Jap, danke. Also wenn ich Ausgaben in den Code mache, scheint er bei

UtilsView.php

$smarty->plugins_dir = array_merge(
        $this->getModuleSmartyPluginDirectories(),
        $this->getShopSmartyPluginDirectories(),
        $smarty->plugins_dir
    );

Explizit führt in UtilsView.php die Methode getSmartyPluginDirectoryRepository zum 500, genau genommen dieser return:

return oxNew(
        ModuleSmartyPluginDirectoryRepository::class,
        $this->getConfig(),
        $moduleVariablesLocator,
        oxNew(Module::class)
    );

und davon der Teil:

oxNew(Module::class)

Vielleicht kann wer damit was anfangen, um der Ursache näher zu kommen.

Das Problem wurde durch ein Drittanbieter-Modul verursacht.

1 Like