Email Versand problembehaftet

Hallo,

wir hosten unsere Email Adressen bei Microsoft. Das führt dazu, dass es teilweise bis zu 10 Sekunden dauert bis der Kunde nach Abschicken der Bestellung zu der “Danke” Seite kommt. Das dauert viel zu lange und viele Kunden klicken dann weg.
Wir haben jetzt als Alternative eine neue Email angelegt, da wo der Shop gehostet wird. Jetzt geht es sehr schnell, da die Anmeldung beim externen Provider weg fällt. Allerdings erhalten ca. 30% keine Email, wir erhalten ständig Fehlermeldungen, dass die Emails vom Empfänger verweigert wurden. Meist mit Hinweis auf fehlende SPF Einträge.
Gibt es da irgendeine Lösung? Beides ist sehr unbefriedigend.

Grüße

Habt ihr verschiedene E-Mail Konfigurationen ausprobiert? SMTP, SSL/TLS, mit Port, ohne, IP statt url.

man könnte die nötigen SPF Einträge in der DNS hinterlegen.

Guckst du hier :wink:

1 Like

Eine Option wäre immer den E-Mail Versand an einen Dienstleister auszulagern. Man unterscheidet dort zwischen Transaktionsmails und Newslettersmails. Bestellungbestätigung Email wäre z.B. eine Transaktionmailing. Der Dienstleister stellt z.B. eine hohe Zustellrate sicher.

Zuerst immer der Blick in den OXID eXchange https://exchange.oxid-esales.com/en/Marketing-und-Kampagnen/E-Mail/

Eine Option ist das natürlich, ja. Aber prinzipiell sollte ein Server so konfiguriert werden können, dass Transaktions-E-Mails zugestellt werden können.

1 Like

Genau das haben wir gemacht und genau deshalb war es notwendig, einen SPF-Eintrag anzulegen.
Grund: der Dienstleister versendet die Mails über unseren Mailserver, damit als Absender der Shop erscheint. Der Provider blockiert jedoch externe Servern aus Gründen des Spamschutzes. Durch den SPF-Eintrag wird dem externen Server die Verbindung ausdrücklich erlaubt und die Blockade somit verhindert.

Danke für die Antworten. Leider kenne ich mich da schlecht aus, das Problem ist wohl, dass der SPF Eintrag zwar vorhanden ist, aber auf Microsoft verweist. D.h. Mails, die nicht über Microsoft verschickt werden, sondern über den Hoster werden als Spam deklariert. Bei SPF-record.de steht:

Die in den DNS hinterlegten MX-Records dürfen keine E-Mails versenden.
domain-de.mail.protection.outlook.com

und

Die in den DNS hinterlegten A-Records dürfen keine E-Mails versenden.

Profihost hat das nun erweitert und folgendes eingetragen:
v=spf1 include:spf.protection.outlook.com ip4:xx.xxx.xxx.111 -all

Ich hoffe, das funktioniert nun.

Grüße

@Maglorix

Wir hatten gerade ein ähnliches Problem. Wir dachten, das sich das Problem mit dem SPF-Record für ip4 getan hatte. Unsere MailLogs und die Rückläufer zeigten aber, das die Server untereinander sich bereits mit ipv6 unterhielten. Da ipv6 auf unserem Server aktiviert war und Google das dankend angenommen hat, war die Zustellung bei ipv6 nach wie vor schwierig.
Gegen eine ipv6-Kommunikation ist auch grundlegend nichts zu sagen, aber bis unser Serveradmin die korrekte ipv6-Konfiguration für den SPF-Record raus hatte (zwei Tage mit tests etc.), haben wir uns temporär mit einem einfachen Mailpostfach beim Webspace-Provider beholfen und dessen SMTP-Server für den Versand genutzt.

Klingt nach Troll, aber: Einfach nicht Microsoft benutzen.

Kam bei uns auch vor und nun verschickt der Shop über eine eigenständige Domain (DNS-A, DNS-AAA, MX, gehört alles ihm).

1 Like

@Mario_Lorenz

wenn die Mails aber bei Microsoft bleiben sollen (für meine Domain), dann müsste man eine Subdomain oder eine neue richtige Domain anlegen oder wie meintest du das mit dem SMTP-Server für den Versand? Ich finde ich es irgendwie nicht so gut, wenn die Bestätigungsemails und die Kontaktanfragen nicht über über die Shop Domain laufen.

@Jonas_Hess

tja, das hatten wir früher und es war eigentlich auch völlig ok. Es ist halt schon komfortabel, von unterwegs aus Emails zu bearbeiten wenn es über Microsoft läuft. Die Provider haben meist so ein 0-8-15 Emailzugang, mit dem man nicht richtig arbeiten kann. Zudem dachte ich mir damals, dass die Trennung ganz gut wäre, bei mir ist mal ein der Server abgeraucht und es hat länger gedauert, den wieder an den Start zu bringen. In solchen Fällen kann man zumindest Emails beantworten…

Grüße

@Maglorix: Ich weiß nicht wo Du Deinen Shop hostest. Bei shared-host Providern sind zum Beispiel die Postfächer oftmals über eine neutrale, allgemeine Domain (mit eigener IP) ereichbar. Also unabhängig von der IP des Shops. Dort könntest Du ein Postfach einrichten. Der Shop-Provider prüft i.d.R. beim Versand, ob die Domain der E-Mail, die Du als Absender beim SMTP-Versand nutzt, auch dort konfiguriert ist. So sichert er sich etwas ab. Ich konnte sogar den MX-Record auf einen ganz anderen Server zeigen lassen und trotzdem problemlos das neutrale Postfach nutzen. Der Vorteil bei dieser shared-hosting-Lösung ist auch, das der Provider i.d.R. seine IPs regelmäßig auf Blacklistings bei Google & Co prüft.

Bei einem eigenen Server ist das natürlich nicht so einfach anwendbar, denn der SMTP-Server ist dann i.d.R. exakt auf Deine IP hin konfiguriert. Und da liegt das Problem. Wenn Du wirklich etwas splitten willst, brauchst Du dafür auch separate IPs. Nur Subdomains bei gleicher IP würden da auch nicht helfen.

@Maglorix Letztendlich ist es egal wer, wie oder was deine Mails verschickt (solange die IP natürlich nicht geblacklistet ist). Du brauchst allerdings auf jeden Fall einen validen SPF Record, da dieser den Empfänger zeigt ob dein Server überhaupt berechtigt ist von deiner Domain Mails zu versenden.
Da Spamprüfung heutzutage weit mehr ist als nur prüfen ob die IP auf einer Blacklist steht, solltest du diesen auf jeden Fall haben.

Die in den DNS hinterlegten MX-Records dürfen keine E-Mails versenden.
domain-de.mail.protection.outlook.com

und

Die in den DNS hinterlegten A-Records dürfen keine E-Mails versenden.

Die Meldung bekommst du da in deinem SPF Record der a und mx Parameter fehlen.

Sollte so aussehen:
v=spf1 a mx include:spf.protection.outlook.com ip4:xx.xxx.xxx.111 -all
und vielleicht noch die IPv6 Adresse :wink:

Danke für eure Unterstützung. Es scheint mit dem Eintrag nun zu funktionieren, die Fehlermeldungen sind massiv zurück gegangen. Wegen IPv6 frage ich bei Profihost nach oder hängt man da einfach die IPv6 Adresse dran, also so: v=spf1 a mx include:spf.protection.outlook.com ip4:xx.xxx.xxx.111 ip6:xx.xxx.xxx.111 -all ?

@Mario_Lorenz
Jetzt habe ich es verstanden. Aber besteht dann nicht wieder die Gefahr, dass es langsam wird wenn bei sharedhost Provider xyz die Anmeldung genauso lange dauert wie bei Microsoft? Oder ist es eher ungewöhnlich, dass Microsoft so lange braucht?

@Maglorix: der ip6-Eintrag sieht anders aus. Allein, weil die IP nicht aus 4 Teilen besteht. Frag Deinen Provider. Und Nein es wird nicht langsam, das “langsam” kommt von Microsoft.