Faulty component --> oepaypalipnconfig

module

#1

wir haben uns seit langem entschieden, das PP-Modul von Oxid eSales zu nutzen.

Die Exception-Log-Datei ist voll mit den unten stehende Exceptions. Was können wir machen, um es zu lösen?

Danke im Voraus.
Gruß,
Diane

        Faulty component --> oepaypalipnconfig
    ---------------------------------------------
    oxSystemComponentException-oxException (time: 2018-09-30 21:03:59): [0]: EXCEPTION_SYSTEMCOMPONENT_CLASSNOTFOUND 
     Stack Trace: #0 .../core/oxutilsobject.php(188): oxUtilsObject->_getObject('oxsystemcompone...', 0, Array)
    #1 [internal function]: oxUtilsObject->oxNew('oxSystemCompone...')
    #2 .../core/oxfunctions.php(368): call_user_func_array(Array, Array)
    #3 .../core/oxutilsobject.php(178): oxNew('oxSystemCompone...')
    #4 [internal function]: oxUtilsObject->oxNew('oePayPalIpnConf...')
    #5 .../core/oxfunctions.php(368): call_user_func_array(Array, Array)
    #6 .../modules/oe/oepaypal/core/oepaypalservice.php(90): oxNew('oePayPalIpnConf...')
    #7 .../modules/oe/oepaypal/core/oepaypalservice.php(305): oePayPalService->getPayPalIpnConfig()
    #8 .../modules/oe/oepaypal/models/oepaypalipnrequestverifier.php(236): oePayPalService->doVerifyWithPayPal(Object(oePayPalPayPalRequest), 'windows-1252')
    #9 .../modules/oe/oepaypal/models/oepaypalipnrequestverifier.php(206): oePayPalIPNRequestVerifier->_doVerifyWithPayPal(Array)
    #10 .../modules/oe/oepaypal/controllers/oepaypalipnhandler.php(171): oePayPalIPNRequestVerifier->requestCorrect()
    #11 .../modules/oe/oepaypal/controllers/oepaypalipnhandler.php(140): oePayPalIPNHandler->requestValid()
    #12 .../core/oxview.php(526): oePayPalIPNHandler->handleRequest()
    #13 .../core/oxshopcontrol.php(359): oxView->executeFunction('handleRequest')
    ..
    ..
    ..
    ..
    ..
    #19 .../index.php(26): Oxid::run()
    #20 {main}

#2

Hallo Diane,

Deutet darauf hin, dass eine Funktion im Template benutzt wird, die an dieser Stelle nicht verfügbar ist - also am Template etwas falsch gemacht wurde.

Funktioniert denn das Modul ansonsten, welche Symptome treten denn auf?
Passt die PayPal-Modulversion zu Eurer 4.10.x?


#3

Danke für die ersten Hinweise.

Das Modul funktioniert ohne sichtbare Probleme.
Dieses Modul war mit Oxid 4.10.x mitgeliefert. Das einzige Problem, das wir manchmal sehen, ist eine Fehlermeldung von PP Express.(Diese Meldung wurde schon unter folgenden Link gemeldet: PayPal Express - Adressinformationen stimmen nicht mit Ihrer PayPal-Lieferadresse überein)

ich prüfe es gleich.