Fehler bei Update von v6.0.0.RC2 auf v6.1.0 ? Maintenance Mode

oxid6

#1

Hallo Community!
Ich war gerade dabei meinen eShop von 6.0.0 RC2 auf 6.1.0 upzudaten, jetzt bekomme ich jedoch nur noch die Maintenance Mode-Seite zu sehen, sowohl beim Shop, als auch im Adminbereich.
Ich habe das ganze nach der Anleitung gemacht.
composer update --no-plugins --no-script lief auch ohne Fehler durch, composer update bescherte mir aber dann folgenden Fehler:

Generating autoload files
> Incenteev\ParameterHandler\ScriptHandler::buildParameters
Creating the “test_config.yml” file
Some parameters are missing. Please provide them.
shop_path (source): Script Incenteev\ParameterHandler\ScriptHandler::buildParameters handling the post-update-cmd event terminated with an exception

[ErrorException]
Use of undefined constant STDIN - assumed ‘STDIN’

update [–prefer-source] [–prefer-dist] [–dry-run] [–dev] [–no-dev] [–lock] [–no-custom-installers] [–no-autoloader] [–no-scripts] [–no-progress] [–no-suggest] [–with-dependencies] [–with-all-dependencies] [-v|vv|vvv|–verbose] [-o|–optimize-autoloader] [-a|–classmap-authoritative] [–apcu-autoloader] [–ignore-platform-reqs] [–prefer-stable] [–prefer-lowest] [-i|–interactive] [–root-reqs] [–] []…`

Und seitdem komme ich nicht mehr auf die Shopseite…
Woran kann es liegen? Wie kann ich es beheben?

Mit freundlichem Gruß
3m7ecc


#2

Hallo 3m7ecc,
mhm, v6.1.0 ? Dachte es gibt erst v6.0.1 ?
Aber vlt. durchschaue ich das Nummerierungssystem noch nicht so ganz oder hab was verpasst …

Gruss
Helmut


#3

Metapackage 6.0.1, eShop Core 6.1.0

https://docs.oxid-esales.com/eshop/de/6.0/releases/releases-2018/oxid-eshop-601.html


#4

ah, danke

OXID eShop 6.0.1

Der OXID eShop 6.0.1 wird als Compilation bereitgestellt. Darin sind OXID eShop 6.1.0, … enthalten

das Wording finde ich allerdings was gewöhnungsbedürftig …