Forms don't display doublebyte characters on refresh

The forms (registration, billing, shipping, etc…) don’t display doublebyte characters properly.

For example, during checkout, entering doublebyte characters is fine however on proceeding to the next step the characters change to their #&12452 #&12505 #&1251&# format. The problem is in the final purchase content confirmation page (last step) and Order History.

Also in Admin reviewing purchases, users, user groups, etc… the same issue comes up. The other fields are fine so I’m not sure what is happening with the UTF-8.

How can I go about fixing this so the characters display properly?

Thank you.

Hi Tokyoj,

are you able to reproduce it in the demoshop? If yes, would you please record a bug entry?
(Sorry, cannot check it by myself … )


The problem is reproduced in all forms on the demo. I reported the bug.

Thanks mate. Unfortunately, we by nature don’t have much experience with double byte char’s.


Thank you. Any idea when a fix might be posted?

btw…using Health Check, confirmed UTF-8 support is enabled.

The Demoshop does not run in UTF-8 for whatever reason. I tried in a shop installed with UTF-8 and inserted characters from here and it displays these characters fine as far as i can see:

Strange the demo demo doesn’t run UTF-8.
Your site with the copy/pasted text displays fine. Hmmmm…

Any idea of why my site is being uncooperative? The only aspect I’ve been working on is the lang.php.

btw way…your site’s theme is excellent. That is exactly what I’m trying to get a friend to do with mine.
Would there be any chance of you sharing the theme? :smiley:

Are you shure you checked the “Use UTF-8 encoding” during installation of the shop? You can verify by looking at the html-source of your shop, it should contain:

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

The theme is a prototype for a customers shop, which itself is a copy of, so i can’t publish the theme. It also contains some modules of my own and some 3-rd party modules. But as i like the minimalistic approach behind it, i thought about making a more generic but also “minimaliist” theme and offer it on exchange, but this may take some time.

Damn ! I was sure UTF-8 was set. View Source code says, “charset=ISO-8859-15”.
In Admin -> Health PHP Config shows UTF-8 Support (green) :confused:

The only way I know how to change the charset is manually edit.
Is there a faster / more efficient way with OXID? (but PLEASE don’t say ‘fresh install’)

I understand about the theme. Sharp and clean looks great. I’ll keep an eye out for your minimalist theme.

Thank you. There is an upgrade procedure available here:, but i never tried it myself. I would recommend backing up everything first.

The “UTF-8 Support” green light only tells you whether your system is UTF-8 capable, but not whether your system is actually running in UTF-8.

Thanks…BUT…it now just displays ??? question marks instead of the HEX entity. #&2322

  • Tested with new accounts, purchases, Admin new products, categories, etc…but…nothing.
  • Checked page source on all forms and they’re all UTF-8 charset.
  • Deleted tmp, cache, etc…
  • Reran /update.php and rechecked Admin, Basic, and new ‘theme’ language files: all UTF-8
  • Confirmed $this->iUtfMode = 1;
  • System Health : all green

even rebooted…

If I may ask, would you (or anyone else) have any other ideas?

(after 2 long days of edits a fresh install is not an option, just in case someone was thinking that :slight_smile:

I appreciate the support…I’m just getting VERY frustrated trying to resolve an issue which really shouldn’t be an issue. :mad:

Did it all again…

Now interface ‘seems’ OK but Forms and Admin still won’t display correctly.

The cause could be the SQL error after uploading utf8_CE.sql


MySQL said:
#1054 - Unknown column ‘OXPIDENT’ in ‘oxorder’

Also to confirm, there are still 5 tables which have Collation as:

My DB skills are low…I’m not sure where to go from here.

Could anyone help? :frowning:

I’ve given in. A fresh install now works.

Thank you for the help. It helped me learn a few things.

[QUOTE=Tokyoj;45601]I’ve given in. A fresh install now works.
Probably the best way if the shop is not productive yet.
In my opinion Oxid should allow only UTF-8 during installation.