Icons for Articles are not Generated in '/generated' directory


#1

Hello everyone,

I have a problem with generating the images for Articles.
When I am adding images to the new or existing product, images are uploaded correctly to Admin-Backend and on the server as a Thumbnail, but are not generated in the:
/out/pictures/generated/product/1…
So, if I try to open in the browser with right click, I am getting: 404 Not Found but the path is generated for the image.

Ex. For the product: Test 1, I added an image: test1.png in the admin backend.
The image exists on the server: /out/pictures/master/product/7/test1.png

But, it is not generated and cannot be loaded in the front of the shop but this URL is generated if I try to open the image in a new tab: /out/pictures/generated/product/3/test1.png

Thanks for your help!


#2

Any idea or suggestion?

  1. While uploading image, there is no errors in the log files
  2. I have permissions 777 in the out directory

Thank you.


#3

shopversion?
theme?

… means it is the 7th picture for this product.
-> try to load the 1st picture in admin backend and have a look if it is shown in frontend


#4

It’s same for all the images.
No matter if I create a new product or add images to existing one, none of the images will be generated and showed in the front of the shop.
Only will exist in /out/pictures/master/product/1,2,3…/test1.png

Shop version is 4.10 and theme is custom made.

I must mention that everything was working fine before the migration from one server to another.

Thank you.


#5

sound like there were no writing permissions for out/* folders


#6

do you have access to server logs?
maybe you find there something like:
PHP Warning: getimagesize(https://www.domain.de/out/pictures/master/product/1/test1.png): failed to open stream: Connection timed out in /homepages/28/d231332571/htdocs/tmp/smarty/…morepics.tpl.php on line 25


#7

Weird thing is that while uploading image to admin-backend, the error logs are open but there is no error generated. I tried with that.


#8

All directories for out/* folders are with 777 rights.


#9

[error] 13178#13178: *4818780 directory index of “/home/website/www/out/pictures/generated/product/1/” is forbidden, client: xx.xx.xxx.1, server: www.website.com, request: “GET /out/pictures/generated/product/1/ HTTP/1.1”, host: “www.website.com

This line is in the error log when CRON tried to generate the image.

It means like permissions but as I mentioned, all folders have 777 permissions.

Thank you!


#10

check if:

has subfolders like “300_300_80” (size of generated pictures)


#11

Yes, folders exists.
And also as I mentioned in my first message if the image, for example, is test1.png, it exists in /out/pictures/master/product/3/test1.png

And when I am trying to open generated image with right click, shop knows that it should be in:
the image in a new tab: /out/pictures/generated/product/3/300_300_80/test1.png

But I am getting 404 not found an image not exist in the directory on the server.


#12

check theme settings, size for generated images should be configured there


#13

Yes sizes are configured.
And also, directory exists where shop is trying to find generated image, but it’s not generated.


#14

then i assume it MUST be a writiing permission to subfolders like xxx_xxx_xx


#15

I just checked again, all of the directories have 777 permissions.


#16

which subfolders are there?
do these correspond to the picture sizes given in theme settings?


#17

Well in Theme Settings I have for example for Article Image #1 following settings:
Extra Small (Phones) 569 * 569
Small (Tablets) 569 * 569
Medium (Desktops) 569 * 569
Large (Desktops) 569 * 569

But on the server, directory is:
569_569_75 and 569_569_75_0

Also, I must mention that when I am trying to upload image from FileZilla, it’s visible in the front of the shop.


#18

thats ok. It means: pictures with width: 569px - height: 569px - quality: 75%
contact the developer of your custom made theme or switch to flow


#19

Okay, I’ll do something because this happens after migration from one server to another so I was thinking that maybe the problem is in the server configuration.


#20

Hi guys, did anyone knows for 100% which function is generating images?

Because I was trying to extend class ‘oxdynimggenerator.php’ and call some of it’s functons like _generateImage(), while uploading image, functions from this class are not called.

Also, I was making some tests in shop locally where generating of the images is working properly, and when I am trying to print something inside the _generateImage() function, it’s printed when I am opening image in the new tab. Which means that image is previously uploaded and generated.

Thanks for your help!