Install problem - PHP memory


Trying to install Oxid CE on a local server. I’m running Mac OSX 10.5.7 with Mamp Pro 1.7.2.

On the system requirements screen , I get the following error

  • PHP Memory limit (min. 14MB, 30MB recommended)

I’m attempted to install Oxid in a folder called ‘oxid’ within the public folder of a Zend Framework app. In the ZF index.php file , I’ve tried to change the memory setting to 16Mb, then 30Mb

  • ini_set(‘memory_limit’, ‘16M’);

I still get the same error message. If I verify the settings with phpinfo() , the memory appears to have been set correctly.

Thanks for your help!


Hi Patrick,

unfortunately, I have no idea how a webserver shall be configured using Zend Framework, yet. No clue if maybe it takes some extra memory…

Do you see the possibility to set up the shop on a “regular” system firstly with memory_limit > 14M in the php.ini?


Marco Steinhäuser
Community Guide
OXID eSales AG

Hi Marco,

Thanks for the quick reply! I’ve managed to solve the problem. Changing the memory limit with ini_set didn’t do the trick, so I just added a line in the .htaccess file. At 16M , the indicator turned yellow, then at 30M it turned green.

After submitting the previous post, I tried a basic install , but then I had two problems :slight_smile: PHP memory limit and mod_rewrite! So the fact it was installed within a ZF app didn’t seem to cause a specific problem.

Right now, everything seems in order!

Many thanks.