Install "testing-library" enviroment on oxvm_base


#1

Hi all!
I have small problem with installation proccess of “testing-library”.

I added to composer.json:
"require-dev": {
“oxid-esales/testing-library”: “dev-master”,
“incenteev/composer-parameter-handler”: “~2.0”
},

like it is described here:
https://github.com/OXID-eSales/testing_library/

and after “composer update” command console throw me this error:
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Conclusion: remove symfony/console v2.8.42
- Conclusion: remove oxid-esales/oxideshop-metapackage-ee v6.1.0
- Installation request for oxid-esales/testing-library dev-master -> satisfiable by oxid-esales/testing-library[dev-master].
- Installation request for oxid-esales/oxideshop-metapackage-ee v6.1.0 -> satisfiable by oxid-esales/oxideshop-metapackage-ee[v6.1.0].
- oxid-esales/oxideshop-metapackage-ee v6.1.0 requires oxid-esales/oxideshop-metapackage-pe v6.1.0 -> satisfiable by oxid-esales/oxideshop-metapackage-pe[v6.1.0].
- oxid-esales/oxideshop-metapackage-pe v6.1.0 requires oxid-esales/oxideshop-metapackage-ce v6.1.0 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.1.0].
- oxid-esales/oxideshop-metapackage-pe v6.1.0 requires oxid-esales/oxideshop-metapackage-ce v6.1.0 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.1.0].
- oxid-esales/oxideshop-metapackage-ce v6.1.0 requires symfony/console v2.8.42 -> satisfiable by symfony/console[v2.8.42].
- oxid-esales/oxideshop-metapackage-ce v6.1.0 requires symfony/console v2.8.42 -> satisfiable by symfony/console[v2.8.42].
- Conclusion: don’t install symfony/console v2.8.42

anybody know what to do with this?


#2

We have somthing like this (6.1.0 EE):

“require-dev”:{
“incenteev/composer-parameter-handler”: “~2.0”,
;“oxid-esales/oxideshop-ide-helper”: “^v3.0.0”,
;“oxid-esales/testing-library”: “v5.0.3”
},


#3

It works. Thanks!