Installallation Ver. 6.1.3 - Fehlermeldungen Composer

Hallo.
Ich habe bei einem Hoster eine dort nicht Update-fähige Version 6.1.3 (Fehlermeldungen mit MariaDB).

Nun möchte ich laut Anleitung:


umziehen.

Hier hänge ich bereits an der Installation von 6.1.3
Mit: composer create-project --no-dev oxid-esales/oxideshop-project shop dev-b-6.1-ce starte ich und bekomme Fehlermeldung:
Your requirements could not be resolved to an installable set of packages.

  • Problem 1*
    • Root composer.json requires oxid-esales/oxideshop-ide-helper ^v3.1.2 -> satisfiable by oxid-esales/oxideshop-ide-helper[v3.1.2].*
    • oxid-esales/oxideshop-ide-helper v3.1.2 requires composer-plugin-api ^1.1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.*
  • Problem 2*
    • ocramius/package-versions 1.2.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.*
    • oxid-esales/oxideshop-metapackage-ce v6.1.6 requires ocramius/package-versions 1.2.0 -> satisfiable by ocramius/package-versions[1.2.0].*
    • Root composer.json requires oxid-esales/oxideshop-metapackage-ce v6.1.6 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.1.6].*

ocramius/package-versions only provides support for Composer 2 in 1.8+, which requires PHP 7.4.
If you can not upgrade PHP you can require composer/package-versions-deprecated to resolve this with PHP 7.0+.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.
Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

Die composer.json editiere ich dann:
{
“name”: “oxid-esales/oxideshop-project”,
“type”: “project”,
“description”: “This file should be used as an OXID eShop project root composer.json file. Entries provided here intended to be examples and could be changed to your specific needs.”,
“license”: [
“GPL-3.0-only”
],
“minimum-stability”: “stable”,
“require”: {
“oxid-esales/oxideshop-metapackage-ce”: “v6.1.3
},
“require-dev”: {
“oxid-esales/testing-library”: “^v5.0.4”,
“oxid-esales/coding-standards”: “^v3.0.5”,
“incenteev/composer-parameter-handler”: “~v2.0”,
“oxid-esales/oxideshop-ide-helper”: “^v4.0.0”,
“oxid-esales/azure-theme”: “^v1.4.2”
},
“autoload-dev”: {
“psr-4”: {
“OxidEsales\EshopCommunity\Tests\”: “./vendor/oxid-esales/oxideshop-ce/tests”
}
},
“scripts”: {
“post-install-cmd”: [
“Incenteev\ParameterHandler\ScriptHandler::buildParameters”,
@oe:ide-helper:generate”
],
“post-update-cmd”: [
“Incenteev\ParameterHandler\ScriptHandler::buildParameters”,
@oe:ide-helper:generate”
],
“oe:ide-helper:generate”: [
“if [ -f ./vendor/bin/oe-eshop-ide_helper ]; then oe-eshop-ide_helper; fi”
]
},
“config”: {
“preferred-install”: {
“*”: “dist”
}
},
“extra”: {
“incenteev-parameters”: {
“file”: “test_config.yml”,
“dist-file”: “vendor/oxid-esales/testing-library/test_config.yml.dist”,
“parameter-key”: “mandatory_parameters”,
“env-map”: {
“shop_path”: “SHOP_PATH”,
“shop_tests_path”: “SHOP_TESTS_PATH”,
“partial_module_paths”: “PARTIAL_MODULE_PATHS”
}
}
}
}

danach starte ich composer update und bekomme nur noch:

Problem 1
- ocramius/package-versions 1.2.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
- oxid-esales/oxideshop-metapackage-ce v6.1.3 requires ocramius/package-versions 1.2.0 -> satisfiable by ocramius/package-versions[1.2.0].
- Root composer.json requires oxid-esales/oxideshop-metapackage-ce v6.1.3 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.1.3].

ocramius/package-versions only provides support for Composer 2 in 1.8+, which requires PHP 7.4.
If you can not upgrade PHP you can require composer/package-versions-deprecated to resolve this with PHP 7.0+.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

PHP ist auf 7.4 eingestellt.

Was muss ich hier tun?

6.1.3 ist nichtmit Composer 2 kompatibel, nur Composer 1

Danke für die schnelle Antwort.
Das heißt ich kann 6.1.3 nicht mehr installieren!?
Welche möglichkeit habe ich dann noch mein 6.1.3 Projekt umzuziehen?

Du kannst composer 1 oder gar kein composer nutzen