Installation problems

I just tried to install oxid (open-source version) for the first time and it does not work.
I uploaded all files and accessed the site with my browser.
However, this is the error message which is then displayed:

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/www/ph14s696/html/index.php on line 94

Can anyone help?
Thanks.

Hi,

your server is running PHP4 obviously, OXID needs PHP5.
You should ask your hosting provider to switch :wink:

Regards

Thanks.
Now that part works.

During installation your system now demands the following:
Apache mod_rewrite Modul

Is this usually just a problem of configuration at my end or how can this be settled?
I already asked with my hosting provider, but sofar have not received the support I need.

Thanks.

mod_rewrite is a PHP option that is required to be be installed on the server by the provider for proper URL rewriting.

This is the reply my provider has given me… by the way in German, but according to your name, I assume German is ok for you :slight_smile:

[I]hierbei sollte der Shop Betreiber schon eine genaue Anleitung vorrätig haben.

Mod_rewrite ist ein Modul welches wir für alle Kunden bereitstellen.

Dieses “Modul” haben Sie bereits für die PHP Umschaltung genutzt. Insofern Sie
Mod_rewrite auch für Ihren Shop nutzen möchten, müsste bei diesem Shop ganz
klar eine .htaccess dabei sein!

Sollten Sie hierbei Probleme haben, so kontaktieren Sie bitte den Hersteller
des Shops![/I]

According to my name, Italian shall be ok fom me :smiley:

So mod_rewrite is hopefully installed on your server.
Could you please check, if a .htaccess file can be found in the root folder of your shop installation?

  • If not - your probably use a unix like operating system at your client like Mac OS or Linux and the .htaccess file was hidden and not transferred to your webspace.
  • If yes - probably a value is missing in your .htaccess. Edit it and add the following parameter:
RewriteBase /shop_folder/

Thanks sofar.

Actually, I could not find the .htaccess file in the root folder, although I know I had uploaded it, to actually get your installation assistant to start up. (I also checked for hidden files…)
I now uploaded it again, with the following content:

AddHandler x-httpd-php .php .php3 .php4
RewriteBase /shop_folder/

As shop_folder I tried the actual folder name "/html/"
How about for the root directory, would I have to enter “/” ?

But I still get the same “red” message from your install.assistant:
Apache mod_rewrite Modul

Sorry for the trouble.

Ok, alright…

Probably, while getting php5 running, your overwrote the original shop .htaccess.
Open up this file and repace it with this content:


<IfModule mod_rewrite.c>

Options +FollowSymLinks
RewriteEngine On
RewriteBase /shop_folder/
RewriteCond %{REQUEST_URI} !(\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteRule admin/test\.php$ admin/test.php?mod_rewrite=1

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(\.html|\/|\.jpg|\.css|\.pdf|\.doc|\.gif|\.png|\.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.html|\/)$ oxseo.php


</IfModule>

# disabling log file access from outside
<FilesMatch "(EXCEPTION_LOG\.txt|\.log$|\.tpl$)">
order allow,deny
deny from all
</FilesMatch>

Options -Indexes
AddHandler x-httpd-php .php .php3 .php4

In case you installed OXID eShop in the so called “doc root” of your server (want to call it like http://www.myshop.com) replace the line RewriteBase /shop_folder/ by

RewriteBase /

In case you installed OXID eShop in a subfolder like /oxid/ (want to call it like http://www.myshop.com/oxid/) replace the line RewriteBase /shop_folder/ like this:

RewriteBase /oxid/

Thanks alot.
That is exactly what happened.

Now everything is functional.
Thanks again.

Hi everybody,
have the same red error about mod_rewrite and the trick mentioned above does not work for me! :frowning:
Have Debian Lenny, Apache 2…

lenny:/home/xxx# a2enmod rewrite
Module rewrite already enabled

Help!!!

Hi Redial,

obviously you run a root server?
Did you think about changing the value for AllowOverride to ALL in your vhost? :slight_smile:

Cheers

Hi Marco,

thx for you reply! This is is just a vm I’m playing with in order to become familiar with eSales.
vhost… well’ I haven’t defined one. I’m trying to run it this way: http://localhost/myEshopFolder/setup/index.php. Will try the vhost thing…

Hi,

maybe this one is helpful as well:
http://www.oxid-esales.com/forum/showthread.php?t=1462

Regards

Hi Marco,
I re-installed apache and all the other stuff and miraculously… it works! Also I had to do a chmod -R 0777 to my shop root folder. Is that how it should be? However, thanks for your help!

Hi,

Also I had to do a chmod -R 0777 to my shop root folder.

This is not the way it should be. You will find a list of all files/folders that have to be chmoded:
http://www.oxidforge.org/wiki/Tutorials/filesystem_permissions

Regards

Thanks, Marco! At this point I’m running this on my laptop in order to check the whole thing out. If I decide to use it, I’ll look for an admin anyway.

Thanks again for your help!

Hi Redial,

which PHP Version you#re using? Have you tried

<?php
phpinfo()
?>

in your shop or rootfolder?

Do you speak about the CE or PE Version?

Hi guys,
I have a problem installing Oxid. I have already installed the following softwares using Zend server community version.

mySQL 5.2 is working well
Apache: 2.2
PHP Version 5.2.11
Zend Framework Version 1.9.6
Zend Server
Zend Data Cache :On
Zend Debugger :On
Zend Guard Loader :On
Zend Optimizer+ 4.1 :On

All PHP extensions listed as a condition are ENABLED.

The following I am not sure. I could not find them in php.ini.
REQUEST_URI set
ini_set allowed

Apache mod_rewrite is ENABLED.

I am using Window 7 64-bit.
I have tried other webshop modules and no problem, mySQL, PHP, Apache are working.
I am using OXID eShop community version.
I normally use port 8080. But I have even tried using port 80. But it still does not work.

I am color blinded that I could not differenciate RED from Green. it would be good for future to write the System Requirments in text or other colors, for the sake of all color blinded using the software.

Just thinking… I cannot test this since I would need to run a fresh install again and I already had my fill :slight_smile:

Do you get a tooltip when you hover over the boxes? If not, see if using Firebug or a built in developer tool in another browser allows you to see the colour name or colour hex value of the system requirement box.

V.

good idea Vmajor. tooltip does not say much but the firebug shows RED error on
[B]apache mod_rewrite module[/B].
Now I checked if mod_rewrite module is enabled in httpd.config in my htdocs root folder. Indeed it is enabled because no # is present before [B]LoadModule rewrite_module modules/mod_rewrite.so[/B].
But still it show error.

Any one with a solution?