JABOMMI No Backend Order Recalculation Modul


#1

[B]Deaktiviert die Neuberechnung der Bestellung im Backend[/B]

Der OXID Shop berechnet standardmäßig Bestellungen im Backend neu, sobald diese aktualisiert werden. Wenn Sie z.B. einen Artikelpreis nachträglich ändern und eine Bestellung, die diesen Artikel enthält, aktualisieren, so wird die Bestellsumme neuberechnet.

Das Gleiche gilt für nachträgliche Änderungen von Rabatten & Gutscheinen, Versandkosten, Zahlartgebühren , Verpackungskosten, Geschenkkartenkosten und Trusted-Shops-Kosten.

Mit dem Modul “JABOMMI No Backend Order Recalculation” können Sie alle Neuberechnung zusammen oder jede einzeln deaktivieren.

http://exchange.oxid-esales.com/de/Auftragsabwicklung-Logistik/Bestellprozess/JABOMMI-No-Backend-Order-Recalculation-1-0-0-Stable-CE-4-8-x.html


BUG bei Bestellung: Summe ändert sich nachträglich
#2

Aber so ein Modul gibt es doch schon?


#3

genau genommen sogar zwei - wobei er das eine davon damals auf die schnelle selbst gebastelt hatte, das andere ist von leofonic

http://forum.oxid-esales.com/showthread.php?p=136315#post136315


#4

Kein schlechtes Modul, wir haben es einigen Kunden empfohlen die Problem mit der Neuberechnung hatten und die waren alle sehr überzeugt.


#5

mensch leute! is das nicht klasse? modulmacher unter sich - und empfehlen sich dann auch noch untereinander weiter… coole community! :smiley:


#6

Moin,

ich habe gerade das Modul für Version 4.7 ausprobiert und habe festgestellt, dass die Preise trotzdem geändert werden.
Nach langer Fehlersuche habe ich die Funktion _calcItemsPriceV47 gefunden
Darin wird sofort ein return aufgerufen! Wenn man das return und den parent aufruf entfernt, scheint es zu funktionieren…


protected function _calcItemsPriceV47(){
       parent::_calcItemsPrice();
        return ;
        // resetting
        $this->setSkipDiscounts( false );
        [...]
}

Heruntergeladen habe ich das Modul von oxid_exchange.Liegt dort eine alte Version?

Andreas


#7

Hallo fwap,

hast du die Version 1.0.1 oder 1.0 runtergeladen? Die neuere Version hat genau diesen Fehler behoben.


#8

Hinweis:
Modul macht Probleme wenn Artikel mit 7% und 19% USt. im Warenkorb sind.
Sobald ich die Bestellung neu speichere, wird der 2. USt.-Wert in der Bestellung nicht mehr angezeigt.
(In der Datenbank sind das die Felder: oxorder.OXARTVAT2 und oxorder.OXARTVATPRICE2) CE 4.8.1
Anbieter Jabommi bietet an dies für 120€ und 300€ zu beheben.

Grüße


#9

Hallo,
Frank hat auch ein Modul geschrieben bzgl. neuberechnung. Funktioniert das auch nicht?

[B]No-Recalc[/B]

Grüße
Rafig


#10

[QUOTE=OXID-Design;157582]Hallo,
Frank hat auch ein Modul geschrieben bzgl. neuberechnung. Funktioniert das auch nicht?

[B]No-Recalc[/B]

Ja, das testen wir z.Zt., m.E. hakt es in Kombination mit dem Modul easyBackendOrder

Verhalten bisher: Nach der Erstellen und Hinzufügen von Artikeln im Backend muss das Modul No-recalc zuerst deaktiviert werden, damit unter Stamm die Zahlungsart gesetzt werden kann, speichern usw. … ZU mühsam und zeitaufwendig so.


#11

[QUOTE=stephanwild;157584]Verhalten bisher: Nach der Erstellen und Hinzufügen von Artikeln im Backend muss das Modul No-recalc zuerst deaktiviert werden, damit unter Stamm die Zahlungsart gesetzt werden kann, speichern usw. … ZU mühsam und zeitaufwendig so.[/QUOTE]

Ok. Da Frank sein Modul gratis ist würde ich den anderen Entwickler diesbezüglich Benachrichtigen.

Grüße
Rafig


#12

[QUOTE=OXID-Design;157582]Hallo,
Frank hat auch ein Modul geschrieben bzgl. neuberechnung. Funktioniert das auch nicht?

[B]No-Recalc[/B]

Grüße
Rafig[/QUOTE]

Kurze Ergänzung: Das Modul No-Recalc läuft ohne Probleme bzgl. verschiedener Steuersätze


#13

Also, geht doch. :wink:

Grüße
Rafig


#14

Hallo,

wir haben nun unser Modul in der Version 1.0.3 rausgebracht, welches kompatibel mit [B]Oxid CE/PE >= 4.9x[/B] ist.


#15

Der Bug besteht leider auch noch in der 4.10 Version. Ich habe das Modul gerade installiert. Gibt es schon Erfahrungswerte in der aktuellen Version?

Vielen Dank für die Bereitsstellung des Moduls. Mich ärgert die Sache immer wieder.


#16

Ist der Bug denn in der V6 behoben?


#17

NEIN, von OXID Seite ist das Problem auch in 6.1.x NICHT behoben! Was eine echte Schande für oxid ist.


#18

Ok, das ist allerdings sehr schade. Ich hatte damals bereits die Hoffnung, dass dieser Fehler irgendwann behoben wird. Ich hoffe, es erbarmt sich ein Forum User und schreibt wieder ein Modul für die V6…

Bis jetzt habe ich noch nicht auf V6 umgestellt…