Klaro! in oxid installiert

hallo, ich versuche der Cookie Consent Klaro! installiert, hier wird einiger schritte beschreibt, ich habe der datei config.js auf der Stammverzeichnis gelegt.

dann habe wie indianer3c sagst, auf der datei base.tpl, die beiden script geschrieben,

<script defer type="text/javascript" src="/bilder/cookies/config.js"></script>
<script defer type="text/javascript" src="https://cdn.kiprotect.com/klaro/v0.7.18/klaro.js"></script>

aber bekomme nichts…

Bekommst du die Meldung nicht angezeigt, oder was?

  • tmp geleert?
  • mal im Privat-Browsing versucht?

evtl. die config posten

Viel danke für deine antwort!

ja, habe der tmp leer gemacht

ich benutze Chrome Brownser …ich habe der cache leer gemach auch…

evtl. die config posten

in diese datei habe nichts gemacht…aber ich habe wie hier.…, zeigt anderes als deine config.js

Vielleicht das probleme kann sein vom Script, der Erste script,

<script defer type="text/javascript" src="/bilder/cookies/config.js"></script>

/bilder/cookies/config.js muss verändert werden ?, wenn ja, was schreibe ?

Noch ich denke habe andere fehler gemacht…ich habe der Klaro-master Ordner nach source/out/oxid/src gebracht, aber sie aussiehst ein bissen komisch…

wie das Bild zeigt, hat der dateien gebracht, aber nicht die Ordner…

so, auf der script habe so geschrieben,

<script defer type="text/javascript" src="config.js"></script>

dann der datei config.js der auf der Stammverzeichnis ist, habe veränder von was du geschrieben hast, nur habe verändert, "cookieDomain":"https://www.kalamulur.com/", du bei id hast "id":"c6822935e21b10efaaaea24688dc4125", wo bekomme ich diese id ?

Sicher wegen dieser fehler bekomme noch nicht klaro…

Du kannst doch nicht einfach die config.js kopieren und dann glauben, dass funktioniert!!!
https://heyklaro.com/

Hier musst du dich anmelden und deine eigene config.js erstellen, Dann bekommst du auch eine ID

1 Like

Danke, ich bin angemeldet, und jetzt was soll ich mache ?

lesen und probieren. Es gibt dort eine Schritt für Schritt Anleitung. Ein bisschen musst du schon selbst machen.

hast du recht…jetzt versuche der API zu bauen…

Eine frage…der oxid der ich habe, benutze Hubspot ? ich frage es weil in API konfiguration fragt mir…ich habe sie nicht installiert, aber Vielleicht sie war schon installiert wenn ich download habe…