Kleines Problem mit Modul - Admin TPL Override v. vanilla_thunder

Hallo zusammen,

baue mir gerade die V6x vom Shop neu auf und wollte dieses Mal auch von vornherein eine schön strukturierte Trennung der Überschreibungen der Admin Templates hinbekommen.
Dabei bin ich auf das kleine Tool Admin TPL Override gestoßen und finde es gut gelöst.

Jetzt gibts doch ein kleines Problem bei der Verwendung und überschreibung von Blöcken.
Mal am Beispiel der home.tpl erläutert:

  • ich ersetze die home.tpl in dem Modul durch meine myhome.tpl.
  • dann setze ich in die myhome.tpl einen Block, den ich dann wiederum in einem eigenen Modul nutze um ihn zu befüllen.

Und genau das funktioniert nicht. Der Block ist registriert in der DB, alles chick und auch Cache gelöscht etc. Wenn ich das Modul ‘Admin TPL Override’ deaktiviere und den Block direkt in die home.tpl setze, funktioniert alles anstandslos.

Hab auch schon mal versucht, die Sortiereihenfolge der Module unter ‘OxidEsales\Eshop\Application\Controller\Admin\NavigationController’ zu ändern, leider ohne Erfolg.

Ich sehe momentan nicht, warum das mit dem Modul nicht funktioniert. Das Modul erstezt im Grunde doch nur die home.tpl durch meine myhome.tpl und in der sollten sich dann doch auch Blöcke normal nutzen lassen?

Vielleicht hat jemand eine Idee?

cooper

Was steht denn in oxtplblocks__oxtemplate als Adresse?

ja, du hast Recht, da stand tatsächlich noch die home.tpl drin.
Hab ich jetzt geändert auf myhome.tpl und siehe da, es läuft.

Manchmal ist man auch echt betriebsblind! :sleeping:

Thanks…
cooper

Gerne. Dann bitte als erledigt markieren.