LegacyTemplateNameResolver::resolve() must be of the type string - Error thrown when am trying to add product to the basket

Hello guys,

I have a module that extends the variant selections block and AJAX call implement there. And, everything is working great, but when the module is active when I am trying to add an item in the basket, I am getting the following error:

OXID Logger.ERROR: Argument 1 passed to OxidEsales\EshopCommunity\Internal\Framework\Templating\Resolver\LegacyTemplateNameResolver::resolve() must be of the type string, null given, called in /var/www/html/oxid_fresh_19_04_2020_test/vendor/oxid-esales/oxideshop-ce/source/Internal/Framework/Templating/Loader/TemplateLoader.php on line 103

What module is it? What happened to make it stop working? Did you upgrade the shop? If so, which Oxid version did you use before (when the module worked) and which version do you use now? etc. etc.

1 Like

As I mentioned above, in the block for variant selection, I implemented an AJAX call that is working okay. But when module is active, and when I am trying to add item in the basket, I am getting the error mentioned above in the post.

The module is still in development mode (OXID 6.2).
The only thing that I can see is that the error is thrown from the class for testing in OXID, and that some parameter in my OXID call is missing. So, I am guessing which one…

My AJAX call looks like this:

<form id="uploadImageFormSubmitForm" action="[{$oViewConf->getSelfActionLink()}]" method="post">
	[{ $oViewConf->getHiddenSid() }]
	[{ $oViewConf->getNavFormParams() }]
	<input type="hidden" name="cl" value="test">
	<input type="hidden" name="fnc" value="save">
	<input type="hidden" name="anid" value="[{$oDetailsProduct->oxarticles__oxnid->value}]">
	<input type="hidden" name="parentid" value="[{if !$oDetailsProduct->oxarticles__oxparentid->value}][{$oDetailsProduct->oxarticles__oxid->value}][{else}][{$oDetailsProduct->oxarticles__oxparentid->value}][{/if}]">
	<input type="hidden" name="panid" value="">
	<label for="myfile">Upload Image</label>
	<input type="file" id="ringimage" name="image">

Sorry the late response but in this moment i had the same error and i know how to fix it. Its only a Problem for OXID 6.2. You can solve it with a return value in the called function. For me a return true; has solved the problem…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.