Maintenance Mode CE6.3.1

Hallo,

ich habe von der CE6.2.1 auf die CE6.3.1 geupdatet.

Weil das mit Composer (etwas zerschossen) nicht funktionierte habe ich:

  1. die CE6.3.1 neu aufgesetzt
  2. Roxive installiert
  3. das Modul zum Cache-Löschen installiert
  4. die DB der CE6.2.1 ohne “oxconfig” und “oxconfigdisplay” in die DB der CE6.3.1 importiert
  5. vendor/bin/oe-eshop-db_migrate migrations:migrate
  6. “tmp”-Ordner gelöscht
  7. vendor/bin/oe-eshop-db_views_generate

Frontend und Backend aufgerufen → funktioniert alles.

Ich habe dann 2-3 Stunden getestet, Einstellungen aus der CE6.2.1 übernommen, Kunden und Bestellungen bereinigt usw.

Dann bemerkte ich, dass der obere Frame fehlte. Beim Versuch des Wiederherstellens erhielt ich bei allen Links und im Frontend den Maintenance Mode.

Habe ich hier eine Tabelle zu viel in die DB importiert? Oder hat jemand eine andere Idee?

mfg

Gert

Steht was im log?

bedeutet, dies Du hast vor längerer Zeit das Update von 6.2.1 auf 6.3.1 vorgenommen.

Dann einige Zeit später hast Du gemerkt, dass irgendetwas nicht stimmt und hast Deine genannten 7 Schritte erneut ausgeführt?

Wenn Du bereits auf 6.2 Serie warst sollten beim Update auf die 6.3 Serie bei der Datenbank Migration nur Änderungen des PayPal Moduls (durch Versionsänderung) in den Migration ausgeführt werden.

Kann es sein, dass das Roxive Theme ein eigenes Caching hat? Und als Du ggfs. durch Schritt 1, 2 oder 6 den Cache des Themes geleert hast und dadurch der Shop in Maintenance Mode gewechselt?

Hallo,

@rubbercut,
das oxid-log hat in den betreffenden 30 Minuten ca. 5000 Einträge

@indianer3c
Das Update (Testsystem) habe ich in ziemlich engen zeitlichen Zusammenhang durchgeführt, also am gleichen Tag.

Datenbank → CE631 installiert → DB - Wiederherstellung aus der CE621 → Datenbank Migration

Also der Maintenance Mode ist beim Löschen von Uralt-Kunden/ bzw. -Bestellungen aufgetreten…

mfg

Gert

Die Vorgehensweise bei einem Update hat sich mit der 6er Version geändert. Die Update Anleitung für 6.2.x auf 6.3.x findest Du unter Update from 6.2.x to 6.3.0 — OXID eShop 6.3 | User documentation

Vorgehen wäre zusammengefasst wie folgt

  1. Produktivsystem in Testsystem clonen: Datenbank anlegen, Daten vom Produktivsystem in Datenbank importieren importieren (ohne View Tabellen), Dateien kopieren und config.inc.php die Zugangsdaten von angelegter Datenbank eintragen, tmp Verzeichnis leeren
  2. Jetzt kann die Anleitung aus der Dokumentation befolgt werden, in Deinem Fall meine oben verlinkte von 6.2.x auf 6.3.x. Über Konsole folgende Composer Befehle aus Anleitung absetzen
composer require --no-update oxid-esales/oxideshop-metapackage-ce:v6.3.1
composer require --dev --no-update oxid-esales/testing-library:^v8.0.0 oxid-esales/oxideshop-ide-helper:^v4.1.0
composer update --no-plugins --no-scripts --no-dev
  1. Jetzt würde ich das vendor Verzeichnis löschen
  2. Vendor Verzeichnis über Composer Befehl aus Anleitung wieder erstellen lassen und tmp Verzeichnis leeren
composer update --no-dev
rm -rf source/tmp/*
  1. Datenbank Migration Befehl absetzen + Datenbank Views neu generieren lassen
vendor/bin/oe-eshop-db_migrate migrations:migrate
vendor/bin/oe-eshop-db_views_generate

Hallo @indianer3c,

ich habe oben geschrieben:

Weil das mit Composer (etwas zerschossen) nicht funktionierte habe ich:

das bedeutet:

Loading composer repositories with package information Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires oxid-esales/oxideshop-ide-helper ^v3.1.2 → satisfiable by oxid-esales/oxideshop-ide-helper[v3.1.2].
- oxid-esales/oxideshop-ide-helper v3.1.2 requires composer-plugin-api ^1.1.0 → found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 2
- oxid-esales/oxideshop-composer-plugin v4.1.1 requires composer-plugin-api ^1.0 → found composer-plugin-api[2.0.0] but it does not match the constraint.
- oxid-esales/oxideshop-metapackage-ce v6.2.1 requires oxid-esales/oxideshop-composer-plugin v4.1.1 → satisfiable by oxid-esales/oxideshop-composer-plugin[v4.1.1].
- Root composer.json requires oxid-esales/oxideshop-metapackage-ce v6.2.1 → satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.2.1].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.
Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
[email protected]:/home/users/passin/www/sibra60$

Da ich auch weiß, dass der Shop etliche Altlasten mitschleppt, hatte ich mich für diese Vorgehensweise entschieden…

Ein anderer Grund ist der Composer. Wenn man regelmäßig damit arbeitet, hat man sicherlich die Befehle für die meisten Anwendungsbereiche an einer Stelle…
Ich mache das 2x im Jahr (Learning by Doing)… Solange alles durchläuft, ist das o.k, aber…

mfg

Gert

Einträge welcher Art? Wenn da was von Views steht, weißt Bescheid. Dann solltest zuerst die Views aktualisieren und wenn der Fehler bleibt, die Felder in den Tabellen kontrollieren.

Das Kernproblem hier, dass Composer ein Fehler meldet wäre mit

composer require --dev --no-update oxid-esales/testing-library:^v8.0.0 oxid-esales/oxideshop-ide-helper:^v4.1.0

aus der Update Anleitung gelöst. Bzw. wurde in einem vorherigen Update von 6.1 auf 6.2 Serie bereits die Aktualisierung des IDE Helper Packages wahrscheinlich vergessen. Das heißt wenn einmal der Wurm drin ist, zieht sich der Fehler immer weiter durch in den nächsten Versionen…

Wenn dies für Dich die Lösung darstellt, dann doch super.

Hallo,

@rubbercut
Die Views habe ich mit “vendor/bin/oe-eshop-db_views_generate” mehrmals generiert.

@indianer3c
Ich werde das Prozedere am WE durchspielen und berichten.

Danke erst mal

Gert

Das heißt nix. Die Fehlermeldungen sind entscheidend.

Ab Version 6.2.3 (ja, innerhalb der patch-Releases…) benötigst du auch composer 2 (da hat sich vor allem die plugin-API geändert)