Mixed Content after SSL implementation

Hi, I have setup an eshop running CE 4.10.4 hosted in Hosteurope.ch and we wanted to move to Cloudflare for automatic SSL setup, and after the process was finished, i enabled “Always use HTTPS”, and “Automatic HTTPS Rewrites”, however the site still doesnt fully move to https. I contacted Cloudflare support and they said that i need to edit the source code to “load resources over a relative path, or directly over https”. Now i’m not a programmer, so i googled how to do that and they all said to edit “img src” in the site’s html code, and i understand that but the problem is that there is no file in my site that contains anything like that. I ran a grep search on the server :grep -r -l “http://mydomain.com”, and the only file names that came up were located in /tmp.

Any advice would be appreciated.

i have no experience with connecting cloudflare to oxid, but first you should try configring your shop to use ssl.

Did you change the config.inc.php for always use HTTPS?

$this->sShopURL = 'https://...'; // eShop base url, required
$this->sSSLShopURL = 'https://...';            // eShop SSL url, optional
1 Like

I found that file and checked the values, and yes; $this->sShopURL = ‘http://mydomain.com’, is using http. This is the other one $this->sSSLShopURL = null;

So if i change these to ‘https://mydomain.com’ SSL is fully implemented right?. Also this value: $this->sAdminSSLURL = null; // eShop Admin SSL url, optional…does changing this to https mean that the admin console will use SSL as well cause i want to connect to the backend securely too.

Thank you for the replies.


In this case you can but don’t need to change $this->sAdminSSLURL, because this url depends on $this->sShopURL;

1 Like

Thank you very much. I’ve been working on setting up SSL for way too long and this fixed it.