Multilanguage NOT working properly!

Hi all.
I have an Enterprise Oxid Shop and it must be multilanguage. Over 10 languages.

As I’ve seen from the database by default Oxid supports maximum 4 languages(the default one plus another 3 implemented as FieldName_[1|2|3]).

As I’ve seen researching, in past versions, we had to modify the oxarticle and oxartextends by hand so that we can add more than 4 languages, but in recent versions I’ve seen that fields fieldName_(5|6…) are added automatically when a new language is added.

I’ve observed that this works only until FieldName_8, meaning 9 languages.
But really this isn’t the real problem.
The real problem is that from the moment I add the fifth language and the FieldName_4 fields are created and I attempt to assign some text to a product in that fifth language for the first time, then the admin page goes wild. No product is listed, no categories are liste and I cannot make any modifications to the products.

When I delete the “_4” field from the tables and delete the cache then everything returns to normal, but I cannot use more than 4 language.
[B]I made test on a fresh install of Oxid and the same problem was identified.[/B]

If someone can help in any way please do so.
Thank you in advance!

I want to add that this thing doesn’t happen in PE edition, only in EE

Hello dragos,

as you already reproduced it in a fresh installation, it really sounds like a bug. Could you please copy & paste your text to the bugtracker so the developers could have a look at it?

Thanks a lot!

Thanks for the quick answer to [B]philipp_grashoff [/B]the problem was solved.

“[B]I think this problem can be solved by updating the DB views after changing database. You can find a button for doing this in Master Settings -> Core Settings -> Mall -> Update DB Views now.[/B]”

Ah ok. Thanks for your reply :slight_smile: