Mysql 8 Support in arbeit?

Hallo an Alle,

Ich lege meinen ersten Shop an und bin auf OXID gestoßen und arbeite gerade mit der Open Source Variante.

Da mein Webhoster nur MySQL 8 anbietet, habe ich leider das Problem mit ENCODE und DECODE.
Für den Moment habe ich mir Probeweise einen eigenen Server angelegt mit MariaDB, aber über kurz oder lang muss MySQL 8 unterstützt werden.

Wird daran schon gearbeitet?

Ich habe mir die Sourcen angeschaut und hätte eine Idee für einen Workaround um weiterhin kompatibel zu bleiben.

Da bei mir die Probleme hauptsächlich bei der Installation auftreten habe ich es mal hier gepostet. Bitte korrigiert mich, wenn ich da falsch liege.

Viele Grüße,
Andy

Hallo AndyD,
OXID CE Version 6.3.1 unterstützt PHP 8

Hallo winde,
Vielen Dank für die schnelle Antwort.

Den Support von PHP8 habe ich auch getestet, der funktioniert einwandfrei. In meinem Fall geht es um MySQL 8.0.

Diese hat die ENCODE und DECODE funktionen entfernt, welche benötigt werden um Werte aus der Tabelle oxconfig zu lesen.

MySQL 8 geht ab OXID 7

Sorry, das hatte ich falsch gelesen.

die Version v7-RC1 sollte aber nicht produktiv eingesetzt werden!
https://docs.oxid-esales.com/developer/en/7.0-rc.1/update/update-6.3.x-to-7.0-rc1.html

Vielen Dank für die schnelle und gute Auskunft.
Das lässt mich beruhigt in die Zukunft blicken :blush:

Ich werde mir die Version einmal probeweise auf meinen Hoster laden und schauen wie sich die Versionen vertragen.