Neu hinzugefügte Module nicht im Backend CE 6.2.3

Hallo,

ich habe gerade ein privates Projekt gestartet und dafür die CE Version heruntergeladen. Beruflich arbeite ich mit der EE und habe sowas noch nie erlebt.
Ich habe mir einige Module heruntergeladen, eigentlich Kleinigkeiten wie Tmp leeren aus dem Backend etc. und in den Modules Ordner kopiert (wie immer). Im Backend werden nur die schon enthaltenen Module bei Installation angezeigt. Die neuen nicht. Ich habe die Rechte der Ordner schon auf 777 gestellt(rekursiv auch auf Dateien), keine Veränderung. Eines der Module ist etwas älter, deswegen bin ich von einer Inkompatibilität ausgegangen (probieren kann man es ja mal :slight_smile: Aber eins der Module ist für 6.1 freigegeben. Da würde ich davon ausgehen, dass es zumindest im Backend angezeigt wird. Lange Rede… hat jemand sowas schon erlebt? Eine Lösung gefunden? Ich habe hier im Forum und bei Google alles durch, was dem Fehler auch nur nahekommt. Ich wäre für jede Hilfe sehr dankbar.

LG,
Malham

Ja Module haben neuerdings 4 Zustände ab der Serie 6.2 und müssen vorab registriert werden damit Sie im Admin erscheinen weitere Infos unter Best practice module setup for development with composer — OXID eShop developer documentation 6.2.0 documentation

Dann aber nur bis 6.1. Wie indianer3c bereits geschrieben hat, wirst ab 6.2x dasselbe erleben, wenn Du die Module nur in den Ordner lädst, weil sie angemeldet werden müssen.

Hallo,

erstmal danke für die Antworten.
Wenn ich das richtig verstehe, dann bedeutet das, dass ich das nur per Konsole machen kann, oder? Ich habe ein Webpaket bei Strato, mit dem direkter SSH Zugriff nicht möglich ist. Das Paket ändern möchte ich dafür eigentlich nicht. Ich sehe keine andere Möglichkeit, außer alles auf 6.1 neu aufzusetzen. Oder hättet Ihr in dem Fall noch einen Plan B?

Zunächst in der lokalen Entwicklungsumgebung zusammenbauen und dann per FTP zu Strato hochjodeln.

Guten Morgen,
entschuldige, dass ich nicht früher antworte. Ich habe es gestern Abend noch gelesen, war da aber mitten in einer anderen Sache. Das ist eigentlich ein guter Workaround. Ich frage mich aber schon, warum die Modulintegration so verändert wurde, wenn es vorher doch komfortabel lief. Ich überlege tatsächlich, ob ich das System wechsele oder halt downgrade (was aber echt schwachsinnig ist). Auf jeden Fall vielen Dank für die Info. Und Respekt an Euch, ich sehe ständig, dass Ihr den Leuten inkl. mir jetzt super Tipps gebt. Nicht selbstverständlich. LG

2 Likes

Ich wollte mich jetzt über Stato auslassen aber lasse es lieber!

Nein, kannst du ruhig machen :joy: Das günstigste Paket liegt dann bei mind. 20 Euro im Monat. Und man bekommt 20 Domains, 75 Datenbanken etc. Was soll ich mit so einem riesen Paket. Wurde sowieso schon abgezockt, als ich einfach automatisch upgegraded wurde und plötzlich fast das doppelte zahlen musste.

Waren auch bei Strato.
Immer mal wieder haben die was geändert und dann traten Probleme auf.
Einmal lief eine Woche die PayPal Anbindung nicht, und die Supporter haben überhaupt keine Ahnung.
Seit 2 Jahren HostEurop und Alles prima.
Einen SSH Zugang haben die wohl nicht.
Mache alles lokal und dann per ftp auf den Server