Nicht alle E-Mails werden verschickt bei Bestelliung mit Kreditkarte

Wir haben ein Problem mit Oxid 6.2.4 und dem Payment Erweiterung payplace.express 1.7.2. Wenn Kunden mit der Kreditkarte einkaufen, gibt es immer wieder Kunden bei denen der Versand der E-Mail an Shopbesitzter und Kunden nicht stattfindet. Das ist aber nicht so bei allen Kunden, bei manchen Kunden wird alles Ordnungsgemäß verschickt und wir haben auch noch kein Muster gefunden, bei welchen Kunden es funktioniert und bei welchen Kunden es nicht funktioniert. Im Backend der Zahlungsanbieters ist keine Besonderheit zu finden. Das einzige was auffällt ist, das bei Kunden die keine Mail erhalten, es auch keinen Eintrag in der Historie gibt. Verschickt werden die Mails über Mailjet, da sollte es auch keine Unregelmäßigkeiten geben.

Hat jemand schon mal was ähnliches gehabt? Oder vielleicht eine Idee.

thanks

hauke

Sind die Bestellungen denn in der DB hinterlegt?
ich hatte mal einen seltsamen Fall, da hat die Antivirensoftware die Umleitung vom Payment Provider zurück in den Shop blockiert, so dass die Bestellung gar nicht abgeschlossen wurde.

Wenn es jedoch Bestellungen gibt, such mal in der source/log/oxideshop.log nach Einträgen mit passendem Zeitstempel

wir hatten mal einen ähnlichen Supportfall mit klarna und unzer, wenn ein Kunde zuerst klarna nutzen wollte aber dann zu unzer wechselte wurde nicht die unzer email genutzt - das Resultat war ähnlich wie im hiesigen Fall

Es gibt im Standard des OXID eShops eine Funktionalität die verhindern soll, dass E-Mails doppelt versendet werden. Dies könnte ggfs. eine Konstellation sein wo die Verhinderung nicht erwüncht ist. Dies müsste man im Detail reproduzieren und Bug-Report auf machen.

Selbst auch schon Erfahrung gemacht, aber hauptsächlich in Testumgebungen im Bestellprozess.

Ja, die Bestellungen werden im Backend angelegt. Danke für den Hinweis auf das Log-Datei, ich schau mal rein.