Oxid 6.1.0 CE, force_sid, https & 404


#1

Moin,

so langsam verzweifle ich. Habe vorhin das Update auf v6.0.2 auf tv6.1.0 via Composer ausgeführt, hat nach Anfangsschwierigkeiten geklappt, nachdem ich eine Modifikation der composer.json durchführte (“require-dev”: {“oxid-esales/testing-library”: “^v5.0.0”)…

Ich hatte in den vergangenen Wochen den mod_rewrite-Fehler im Backend, den ich dann auch mal in Angriff genommen habe. Eine Änderung der config_inc.php schaffte Abhilfe ($this->sShopURL = ‘https://www.retroniks.de/shop/source’; // eShop base url, required statt wie vorher “http”).

Nun gut - begann dann den ersten Artikel einzustellen und laufe knallhart in den force_sid-Fehler, der öfter mal geschildert wurde. Also in den vergangenen sechs Stunden alle Lösungsansätze hier durchgelesen und Trial-and-Error gespielt… leider bleibts beim Error.

Rufe ich den einzig verfügbaren Artikel im Shop auf, so bekomme ich einen 404…

Inhalt meiner httpaccess, die im Ordner /shop/source liegt:

<IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /shop/source

    RewriteCond %{REQUEST_URI}     config\.inc\.php [NC]
    RewriteRule ^config\.inc\.php  index\.php       [R=301,L]

    RewriteCond %{REQUEST_URI} setup   [NC]
    RewriteRule ^setup(.*)$    Setup$1 [R=301,L]

    RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
    RewriteRule .* - [F]

    RewriteCond %{REQUEST_URI} oxseo\.php$
    RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
    RewriteRule oxseo\.php$ oxseo.php?mod_rewrite_module_is=on [L]

    RewriteCond %{REQUEST_URI} !(\/admin\/|\/Core\/|\/Application\/|\/export\/|\/modules\/|\/out\/|\/Setup\/|\/tmp\/|\/views\/)
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule !(\.html|\/|\.jpe?g|\.css|\.pdf|\.doc|\.gif|\.png|\.js|\.htc|\.svg)$ %{REQUEST_URI}/ [NC,R=301,L]

    RewriteCond %{REQUEST_URI} !(\/admin\/|\/Core\/|\/Application\/|\/export\/|\/modules\/|\/out\/|\/Setup\/|\/tmp\/|\/views\/)
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule (\.html|\/)$ oxseo.php


    RewriteCond %{REQUEST_URI} (\/out\/pictures\/generated\/)
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule (\.jpe?g|\.gif|\.png|\.svg)$ getimg.php [NC]

    RewriteRule ^(vendor/) - [F,L,NC]
    RewriteRule ^migration - [R=403,L]
</IfModule>

# disabling log file access from outside
<FilesMatch "(EXCEPTION_LOG\.txt|\.log|\.tpl|pkg\.rev|\.ini|pkg\.info|\.pem|composer\.json|composer\.lock|test_config\.yml)$">
   <IfModule mod_authz_core.c>   
       Require all denied
   </IfModule>
   <IfModule !mod_authz_core.c>
       Order allow,deny
       Deny from all   
   </IfModule>
</FilesMatch>

# Prevent .ht* files from being sent to outside requests
<Files ~ "^\.ht">
    <IfModule mod_authz_core.c>
        Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
        Order allow,deny
        Deny from all
    </IfModule>
</Files>

Options -Indexes
DirectoryIndex index.php index.html
</code>/

Gerne liefere ich mehr Informationen auf Zuruf…

Vielen Dank im Voraus,
Ralf


#2

Offenbar versteht OXID keine Kategorienamen die nur aus Ziffern bestehen.


#3

Ach - eben wollte ich schon schreiben ‘meine Kategorien tragen doch eindeutige Bezeichnungen aus Buchstaben bestehend’, aber klar - Unterkategorie ‘2600’. Muss ich mal prüfen…

Nachtrag: Bingo! Genau das ist der Fehler. Eine Änderung in einen alphanumerischen Bezeichner behebt den Fehler.

Vielen Dank, leofonic!

Grüße,
Ralf