OXID 6 Admin loggt aus bei Artikelanzeige

oxid6

#1

Ich habe eine plain vanilla Testinstallation von OXID v6 beta3 mit den Demodaten.

Problem: wenn das Modul “WYSIWYG Editor + Mediathek” aktiviert ist, werde ich beim Versuch des Anzeigens eines Artikels im Admin (Klick auf einen der Artikel in der Liste) ausgeloggt und auf die Anmeldeseite umgeleitet. Das passiert auch, wenn die Artikelbeschreibung völlig leer ist.

Bei deaktiviertem Modul tritt das nicht auf.

Weder im OXID-log noch im Server log erscheint eine Fehlermeldung.

Kann mir jemand einen Hinweis geben, wo ich noch suchen könnte?

P.S. genau denselben Effekt habe ich übrigens bei der v4.10.6 PE (sowohl auf dem Test- als auch auf dem Produktionsserver), wenn ich dort den Visual CMS-Editor aktiviere. PHP ist überall 5.6.30.


#2

da es eine PE ist (und das Modul gar nicht in einer CE vorhanden ist), würde ich den OXID Support unter Druck setzen. Dank dem SWV müssen sie sich damit auseinandersetzen.


#3

@vanilla_thunder: Es handelt sich bei der v6 RC3 nicht mehr um den WYSIWYG-pro, der fest in PE/EE eingebaut war, sondern um den Editor ‘Summernote’, der nunmehr als aktivierbares Modul in allen Editionen verfügbar ist. Wir müssen mal individuell schulen :slight_smile:

Wenn man beim Aufruf dieser Seiten ausgeloggt wird, liegt die Vermutung nahe, dass man aus der Session geworfen wurde. Das kann mit Einstellungen auf dem Server zusammen hängen, wenn z.B. der suhosin-Patch (hardened PHP project) nicht genügend Zeichen für die Session vorsieht.


#4

Sorry, habe mich vielleicht nicht ganz klar ausgedrückt. Die erste “plain vanilla”-Installation ist eine CE mit dem Modul “WYSIWYG Editor + Mediathek”, das bei der CE offensichtlich von Haus aus mit dabei ist.

Die zweite ist eine PE 4.10.6 - eine völlig andere Installation auf einem anderen Server -, aber dort gibts interessanterweise exakt denselben Effekt mit dem “Visual CMS”.

Ich werde aber bzgl. der PE mal beim OXID-Support anfragen.


#5

okay, ich dachte dass v6 PE vielleicht auch einen anderen Editor hätte, den die CE nicht hat.
Schau mal in die Systeminformation (den php_info dump im Backend), was steht da relativ weit unten bei error_reporting und error_log? Bei einigen Hostern sind Fehlerlogs standardmäßig deaktiviert, daher könnte der webserver error log leer sein.
Aber sonst stimme ich Marco zu, logout im Backend ist in der Regel ein Session Verlust, allerdings funktioniert es in meiner V6.