OXID eShop 6 update fails when using a database port different to 3306

Presently OXID eShop 6 (for example 6.0.1 to 6.0.2) update fails when running paragraph four of this tutorial: https://docs.oxid-esales.com/developer/en/6.0/update/eshop_from_6x_to_6y/update_default.html if another port than 3306 is necessary for the MySQL database.

$ vendor/bin/oe-eshop-db_migrate migrations:migrate

Error message:
Access denied for user @'' (using password: YES)

@ivoba sent a pull request that fixed this issue (thanks!), it was already merged:

However, these changes will be released with OXID eShop 6.0.3.


  • Edit existing project composer.json file
  • add to require section:
    "oxid-esales/oxideshop-facts": "v2.2.0 as v2.1.0",
    "oxid-esales/oxideshop-doctrine-migration-wrapper": "v2.1.2 as v2.1.1"
    This will switch components version from defined in the metapackage to newer ones.
  • If you dont use development dependencies run "composer update --no-dev", if you are using dev dependencies run "composer update".

This error still exists when installing OXID Shop at Profihost.

OXID eShop 6.0.3 is not released yet. Expect the release on July 31st.

I hope you look at this error one more time before you make the next release. Because it is still not fixed.

Me, another agency and profihost took several hours to debug and there are definetly several bugs within the setup routine.

The Setup does NOT run when you take another Port within the setup routine. I had a call with an agency and we found that the Routine runs. Yes. But not with a changed port!

Installing like described in this Thread does not work!

And there are more failures within the routine:

  • when taking for example Port 3307, the first connect seems to run properly. But at step 5 the routine throws an error. The connection seems to be lost or changed.
  • when using Port 3307 as Standard Port with the help of php.ini the setup routine runs too. Or if you use Port 3306 which is wrong at profihost because this is the port of mariadb.
  • after installing with Port 3307 within the setup routine and the setting in the php.ini, it is really “funny” that within the config.inc you can see that the port is 3306.

Sorry Marco, now I took a lot of hours to debug This shouldn’t be my work ;-(