OXID VM Einrichtungsproblem

#1

Hallo Community,

ich sitze nun seit einiger Zeit vor der Aufgabe, ein bestehendes Projekt lokal auf meinem Rechner laufen zu lassen.

Ich richte mich dabei hier nach: https://github.com/OXID-eSales/oxvm_eshop

Vagrant, VBox, Git, OpenSSH + VagrantHostmanager & VagrantTriggers sind natürlich vorhanden.

Meine personal.yml lege ich mit folgendem Inhalt an:

vagrant_local:
  vm:
    name: oxvm_box
    hostname: project.local
    aliases:
      - www.project.local
apache:
  docroot: /var/www
php:
  install: true
  packages:
    - php5.6-cli
    - php5.6-intl
    - php5.6-mcrypt
    - php5.6-mysql
    - php5.6-gd
    - php5.6-curl
    - php5.6-xml
    - php5.6-zip
eshop:
  source:
    repo: https://github.com/project.git
    version: master

Wenn ich nun vagrant up ausführe kommt als alles erstes die Meldung:
“Vagrant has detected the vagrant-triggers plugin. This plugin conflicts with the internal triggers implementation.”

Die Meldung hatte ich bei früheren Einrichtungen bereits, wobei ich die VM nutzen konnte und nicht folgender Fehler aufgetreten ist:

...
default: [  3.73s] Install php 7.1 ------------------------------------------------------
default: [  3.12s] Use force-less umount ------------------------------------------------
default: [  3.01s] Gathering Facts ------------------------------------------------------
default: [  2.24s] Ensure mysql upstream repository is installed ------------------------
default: 
default: Playbook finished: Thu May  9 18:11:02 2019, 58 total tasks. 0:02:10 elapsed.

The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Ich weiß nicht wo der Fehler aufeinmal herkommt. SSH sollte eigentlich passen:

$ ssh -V
OpenSSH_7.9p1, OpenSSL 1.0.2p 14 Aug 2018

Mit vagrant ssh komme ich auch in den Server rein.

Beim Aufrufen der Adresse in meinem Host-Browser erscheint jedoch eine 403-Fehlermeldung.

Der generierte Ordner meines Projekts in oxvm_eshop ist auch komplett leer. Vom Git wird also nichts heruntergeladen.

Die einzige Fehlermeldung, die ich im Verlauf sehe ist:

default: TASK [php : Install php 7.1] ***************************************************
default: fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “No package matching ‘php7.1’ is available”}

Dabei hatte ich in der personal.yml eigentlich php5.6 angefragt. Aber auch bei kompletten Standardeinstellungen kommt es zu dem gleichen Fehler.

Das ganze läuft ohne Änderungen meinerseits über Ubuntu 14.04.6 LTS.

Ich hoffe ihr könnt damit etwas anfangen.

Danke euch.

Viele Grüße

Marvin

#2

Hi Marvin,

ich glaube, da gibt es momentan ein kleines Problem mit der VM. Hier wird ein schneller Workaround beschrieben: https://github.com/OXID-eSales/oxvm_eshop/issues/40.

Gruß
Jürgen

1 Like
#3

Das sieht sehr vielversprechend aus. Danke dir Jürgen