Oxid6 Shop HTML-E-Mails in Gmail "zerschossen"

Wir verwenden jetzt Oxid CE 6.1.3 (Wave Theme), bei CE 4.9.9 (Azure) gab es dieses Problem nicht.

Die vom Shop verschickten HTML-E-Mails werden in Gmail (sowohl Browser wie auch Android App) falsch dargestellt, das HTML ist komplett zerschossen, die Tabellen nicht ordentlich usw.

In anderen E-Mail Clients (Thunderbird, Opera Mail, Outlook Online) werden die Mails korrekt dargestellt.

Wie kann ich dafür sorgen, dass sie auch in Gmail korrekt dargestellt werden?

Danke!

Hi Alban :slight_smile:

das natürlich ärgerlich, dass die HTML E-Mails in Gmail zerschossen sind.

  1. Herausfinden wo genau der Darstellungsfehler im HTML liegt
  2. Code-Stelle im E-Mail Template korrigieren
  3. Test Mailing auslösen um zu kontrollieren ob Darstellungsfehler behoben

Hi indianer3c,

danke, der Code der E-Mails schaut an sich nicht falsch aus, funktioniert ja auch in anderen Clients. Kann ich im Oxid einstellen, dass die Plain Text Version NICHT verschickt wird, dass würde ich mal probieren, bevor ich in den Oxid Code und ins Template gehe.
Gibt es einen Debug Modus für GMail, wie den Developer Modus im Chrome, wo ich den Quelltext der E-Mail ändern kann und direkt das Ergebnis betrachten kann?

Unter folgenden links kann man alle gängigen Email-Clients professionell testen und den Code editieren:
https://litmus.com/email-testing


PS: Das ist eine Wissenschaft für sich.

1 Like

Nein, nicht das ich wüsste. Es wird Plain + HTML Version verschickt.

Damit habe ich mich noch nicht beschäftigt. Den verlinkten Service von @Earlybird könntest testen und rumspielen.

Plain Version ist ja auch nur ein Template, das man leeren könnte, aber: wenn man plain Version weglässt, dann halten outlook und greyhound die HTML Version für plain Version und der Kunde bekommt den ganzen Quelltext zu sehen :smiley:
Man sollte also schon beide Versionen mit Inhalt befüllen.

Heyho,

ein kurzer (nicht validierter) Einwurf von einer Waldlichtung im Schwarzwald, an der wir gerade Pause machen.

Ich hatte mit dem Wave Theme vor einer Weile das Problem, dass das Inline CSS für Googlemail zu lang war. Google akzeptiert da nur eine gewisse Länge und schmeißt den Rest einfach weg. Ich hatte das dann in kleinere Tranchen gesplittet und hatte dann keine Probleme mehr. Einfach mal bei Google danach suchen. Die genaue Länge weiß ich nicht mehr.

Vielleicht hilft‘s.
Grüße und schönes Wochenende,
Thorsten

2 Likes

Vielen Dank an alle für die schnellen und wertvollen Hinweise!

@tj_schneider Special Thanks! :slight_smile: Das wars, ich habe in Zeile 433 der header.tpl

</style>
<style type="text/css">

eingefügt dann gings. (Gmail mag nicht mehr als 16k css am Stück…)
Mit kleinen Einschränkungen beim css der Social Links unten in der Box und ein paar paddings/margins, das schau ich mir bei Gelegenheit genauer an.
Weiterhin viel Spaß im Schwarzwald und an alle ein schönes Wochenende!

1 Like