Pdf-invoice - Modul kann nicht geladen werden

Hallo zunächst einmal bin ich mir nicht ganz sicher ob ich hier richtig bin oder im Newbies-Forum.

Ich habe versucht pdf-invoice von hier:


via composer zu installieren.

Bei den Modulen wird invoicw angezeigt, aber : Modul kann nicht geladen werden

Ich habe hier mal die entsprechenden Zeilen aus SSH raus kopiert.
Unten wurde ich gefragt, ob ich Module überschreiben möchte.
Muss ich dort überall J eingeben.
Beim wysiwyg habe ich mal J gemacht, da ich dort eh noch den Bug drin habe, in der Hoffnung, dass er gerade mit erledigt wird.
Sind das alles Updates für den Shop?
Und der Hinweis auf die Parameter am Ende?

-Using version ^2.1 for oxid-projects/pdf-invoice-module
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 45 installs, 0 updates, 0 removals

  • Installing oxid-projects/pdf-invoice-module (v2.1.1): Downloading (100%)
  • Installing symfony/dom-crawler (v2.7.51): Downloading (100%)
  • Installing sebastian/version (1.0.6): Downloading (100%)
  • Installing theseer/fdomdocument (1.6.6): Downloading (100%)
  • Installing doctrine/instantiator (1.2.0): Downloading (100%)
  • Installing phpunit/php-text-template (1.2.1): Downloading (100%)
  • Installing phpunit/php-timer (1.0.9): Downloading (100%)
  • Installing phpunit/php-file-iterator (1.4.5): Downloading (100%)
  • Installing sebastian/recursion-context (1.0.5): Downloading (100%)
  • Installing sebastian/exporter (1.2.2): Downloading (100%)
  • Installing sebastian/diff (1.4.3): Downloading (100%)
  • Installing sebastian/comparator (1.2.4): Downloading (100%)
  • Installing phpdocumentor/reflection-common (1.0.1): Downloading (100%)
  • Installing phpdocumentor/type-resolver (0.4.0): Downloading (100%)
  • Installing phpdocumentor/reflection-docblock (4.3.1): Downloading (100%)
  • Installing phpspec/prophecy (1.8.0): Downloading (100%)
  • Installing phpunit/php-token-stream (1.4.12): Downloading (100%)
  • Installing sebastian/global-state (1.1.1): Downloading (100%)
  • Installing sebastian/environment (1.3.8): Downloading (100%)
  • Installing phpunit/phpunit-mock-objects (2.3.8): Downloading (100%)
  • Installing phpunit/php-code-coverage (2.2.4): Downloading (100%)
  • Installing sebastian/finder-facade (1.2.2): Downloading (100%)
  • Installing phpunit/phpunit (4.8.26): Downloading (100%)
  • Installing phpunit/phpcov (2.0.2): Downloading (100%)
  • Installing incenteev/composer-parameter-handler (v2.1.3): Downloading (100%)
  • Installing oxid-esales/php-selenium (v1.0.5): Downloading (100%)
  • Installing symfony/css-selector (v2.8.50): Downloading (100%)
  • Installing behat/mink (v1.5.0): Downloading (100%)
  • Installing oxid-esales/mink-selenium-driver (v1.1.2): Downloading (100%)
  • Installing symfony/browser-kit (v2.8.50): Downloading (100%)
  • Installing symfony/event-dispatcher (v3.2.14): Downloading (100%)
  • Installing guzzle/common (v3.9.2): Downloading (100%)
  • Installing guzzle/stream (v3.9.2): Downloading (100%)
  • Installing guzzle/parser (v3.9.2): Downloading (100%)
  • Installing guzzle/http (v3.9.2): Downloading (100%)
  • Installing fabpot/goutte (v1.0.7): Downloading (100%)
  • Installing behat/mink-browserkit-driver (v1.1.0): Downloading (100%)
  • Installing behat/mink-goutte-driver (v1.0.9): Downloading (100%)
  • Installing mikey179/vfsstream (v1.4.0): Downloading (100%)
  • Installing pdepend/pdepend (2.5.0): Downloading (100%)
  • Installing oxid-esales/testing-library (v5.0.6): Downloading (100%)
  • Installing squizlabs/php_codesniffer (2.9.2): Downloading (100%)
  • Installing oxid-esales/coding-standards (v3.0.5): Downloading (100%)
  • Installing oxid-esales/oxideshop-ide-helper (v3.1.2): Downloading (100%)
  • Installing oxid-esales/azure-theme (v1.4.2): Downloading (100%)
    sebastian/global-state suggests installing ext-uopz (*)
    phpunit/php-code-coverage suggests installing ext-xdebug (>=2.2.1)
    phpunit/phpunit suggests installing phpunit/php-invoker (~1.1)
    behat/mink suggests installing behat/mink-selenium2-driver (slow, but JS-enabled driver for any app (requires Selenium2))
    behat/mink suggests installing behat/mink-zombie-driver (fast and JS-enabled headless driver for any app (requires node.js))
    symfony/event-dispatcher suggests installing symfony/http-kernel ()
    Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
    Package guzzle/common is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Package guzzle/stream is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Package guzzle/parser is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Package guzzle/http is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Writing lock file
    Generating autoload files
    ocramius/package-versions: Generating version class…
    ocramius/package-versions: …done generating version class
    Update operation will overwrite bestit/amazonpay4oxid files. Do you want to continue? (y/N) n
    Update operation will overwrite ddoe/wysiwyg-editor-module files. Do you want to continue? (y/N) y
    Copying module ddoe/wysiwyg-editor-module files…
    Update operation will overwrite oxid-esales/flow-theme files. Do you want to continue? (y/N) n
    Update operation will overwrite oxid-esales/gdpr-optin-module files. Do you want to continue? (y/N) n
    Installing shop package.
    Do you want to overwrite existing OXID eShop files? (y/N) n
    Update operation will overwrite oxid-esales/paymorrow-module files. Do you want to continue? (y/N) n
    Update operation will overwrite oxid-esales/paypal-module files. Do you want to continue? (y/N) n
    Update operation will overwrite oxid-esales/wave-theme files. Do you want to continue? (y/N) n
    Update operation will overwrite payone-gmbh/oxid-6 files. Do you want to continue? (y/N) n
    Update operation will overwrite topconcepts/oxid-klarna-6 files. Do you want to continue? (y/N) n
    Copying module oxid-projects/pdf-invoice-module files…
    Copying theme oxid-esales/azure-theme files…
    Generating OXID eShop unified namespace classes … Done

Incenteev\ParameterHandler\ScriptHandler::buildParameters
Creating the “test_config.yml” file
Some parameters are missing. Please provide them.

Ich würde alle Fragen mit Ja beantworten. Dabei würden natürlich eventuelle lokale Modifikationen überschrieben, deshalb die Abfrage.
Bei den Parameters am Schluss einfach alle Vorgaben akzeptieren.

Meiner Erfahrung nach ist es günstig, vor Änderungen der Moduldateien die Module im Admin zu deaktivieren.

Ansonsten die übliche Vorgehensweise:
tmp-Ordner löschen
OXID-errorlog (log/oxideshop.log) prüfen
Server errorlog prüfen

Weiterhin: Modul kann nicht geladen werden

Module deaktiviert
tmp gelöscht
log gelöscht
Parameter alle mit yes bestätigt
Standardpfade…

sieht dann so aus:
Using version ^2.1 for oxid-projects/pdf-invoice-module
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Package guzzle/common is abandoned, you should avoid using it. Use guzzle/guzzle instead.
Package guzzle/stream is abandoned, you should avoid using it. Use guzzle/guzzle instead.
Package guzzle/parser is abandoned, you should avoid using it. Use guzzle/guzzle instead.
Package guzzle/http is abandoned, you should avoid using it. Use guzzle/guzzle instead.
Generating autoload files
ocramius/package-versions: Generating version class…
ocramius/package-versions: …done generating version class
Update operation will overwrite bestit/amazonpay4oxid files. Do you want to continue? (y/N) y
Copying module bestit/amazonpay4oxid files…
Update operation will overwrite ddoe/wysiwyg-editor-module files. Do you want to continue? (y/N) y
Copying module ddoe/wysiwyg-editor-module files…
Update operation will overwrite oxid-esales/flow-theme files. Do you want to continue? (y/N) y
Copying theme oxid-esales/flow-theme files…
Update operation will overwrite oxid-esales/gdpr-optin-module files. Do you want to continue? (y/N) y
Copying module oxid-esales/gdpr-optin-module files…
Installing shop package.
Do you want to overwrite existing OXID eShop files? (y/N) y
Copying shop files to source directory…
Update operation will overwrite oxid-esales/paymorrow-module files. Do you want to continue? (y/N) y
Copying module oxid-esales/paymorrow-module files…
Copying module oxid-esales/paypal-module files…
Update operation will overwrite oxid-esales/wave-theme files. Do you want to continue? (y/N) y
Copying theme oxid-esales/wave-theme files…
Update operation will overwrite payone-gmbh/oxid-6 files. Do you want to continue? (y/N) y
Copying module payone-gmbh/oxid-6 files…
Update operation will overwrite topconcepts/oxid-klarna-6 files. Do you want to continue? (y/N) y
Copying module topconcepts/oxid-klarna-6 files…
Update operation will overwrite oxid-projects/pdf-invoice-module files. Do you want to continue? (y/N) y
Copying module oxid-projects/pdf-invoice-module files…
Update operation will overwrite oxid-esales/azure-theme files. Do you want to continue? (y/N) y
Copying theme oxid-esales/azure-theme files…
Update operation will overwrite ecs/fixsmartyincontent files. Do you want to continue? (y/N) y
Copying module ecs/fixsmartyincontent files…
Generating OXID eShop unified namespace classes … Done

Incenteev\ParameterHandler\ScriptHandler::buildParameters
Creating the “test_config.yml” file
Some parameters are missing. Please provide them.
shop_path (source): source
shop_tests_path (tests): tests
partial_module_paths (null): null
if [ -f ./vendor/bin/oe-eshop-ide_helper ]; then oe-eshop-ide_helper; fi

oxideshop.log bleibt leer
Jemand eine Idee?

Für was ist die Datei: test_config.yml

… oder gibt es bei Oxid eine Datei, in der Installationsversuche registriert werden, so dass ich irgendwo Einstellungen zurücksetzen kann.

Hi,

eine Datei für fehlgeschlagene Installationsversuche gibt es nicht, aber wenn das Modul schon mal zB. in einen falschen Order kopiert und aktiviert wurde, wird das in der Datenbank gespeichert und kann genau dein aktuelles Problem verursachen.

Ich habe für solche Fällte folgendes Modul, mit dem solche problematischen Datenbank-Einträge des betreffenden Modules bereinigt werden:

Danke
Genau so könnte es sein. Nachdem, was ich alles probiert habe, hatte ich auch mal ein anderes Verzeichnis probiert und ich glaube seit dem Versuch ging nichts mehr.

Ich probiere das Modul heute Abend aus und gebe Rückmeldung.

hallo,

gibt es in modules/oe/ eine vendormetadata.php mit dem Inhalt:
$sVendorMetadataVersion = ‘1.0’;

@ draufgeschaut: Ja die gibt es.

@ nickname es hat mit dem Modul funktioniert Danke