Permanent SSL address

Hello for all! :slight_smile:

[OXID 6.1.1 EE]
I have small problem with SSL settings and redirections…
My target setting is, to have working OXID shop ONLY on https. Even if i will write address http://www.mydomain.pl, app/server should redirect me to https://…

And now we have few cases:

Case 1 - starndard
$this->sShopURL = 'http://www.mydomain.pl’;
$this->sSSLShopURL= ‘https://www.mydomain.pl’;
$this->sAdminSSLURL= ‘https://www.mydomain.pl/admin’;
$this->blForceSessionStart = false;
Result:

Case 2
$this->sShopURL = ‘https://www.mydomain.pl’;
$this->sSSLShopURL= ‘https://www.mydomain.pl’;
$this->sAdminSSLURL= ‘https://www.mydomain.pl/admin’;
$this->blForceSessionStart = false;
Result:

  • It works almost ok but user can still write in browser http://www.mydomain.pl. Page can be opened but with errors to extenrnal links to google fonts or icons, etc.
  • In addition i have bug with “white page” redirection while logout button from article view which have set visibility rights in admin panel ({Article}>Rights>Assign User Groups) - i found workaround for this issue by set “sSSLShopURL” to null.
    https://bugs.oxid-esales.com/view.php?id=6946

Case 3
Set force redirection on server (apache / in virtualhost).
$this->sShopURL = ‘https://www.mydomain.pl’;
$this->sSSLShopURL= null;
$this->sAdminSSLURL= null;
$this->blForceSessionStart = false;
Result:

  • It works in 99,9%.
  • But some modules like “CleverReach Connector” require setting like: ‘sSSLShopURL’. :frowning:

Any suggestion how to find right way to fix it?

Yes, just use case 2 + Apache Redirection ^^

1 Like

Yes… but still have error probably related to SSL…

Possible this helps:
use your case 2 and add this in yoour htaccess below RewriteBase /
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www. [NC]
RewriteRule (.*) https://www.mydomain.pl/%{REQUEST_URI} [R=301,L]

1 Like