Picture upload is not working (php upload error 3)

Hi!

I’m trying to solve this since three hours and I’m giving up:

Picture upload fails with: ‘The uploaded file was only partially uploaded’, but demo pictures can be deleted via admin interface.

client: ff 46.0
shop ver: CE 4.9.8
os: fbsd
server: apache 2.4.17 running as www
php56: uploads on, 20M allowed, uploads to: /tmp/
permissions: www:www chmod 777

PHP & oxid does not log any error…

Any suggestions?

SLL

Did you try different pictures and different browsers?

Tried it with FF on my Win machine and on my smartphone with different pictures; both fail, but uploading to the oxid demos shop works.

Just tried it with chrome and IE and both fail even more - after clicking ‘save’ you end up on the admin login screen. :confused:

By chance I discovered that files below 10Kb size could be uploaded and from there I managed to find the cure. Unfortunately without really knowing what is going wrong:

Check if you have port option OPTIONS_FILE_SET+=AP2FILTER (Apache 2 Filter) on for mod_php56, but PHP configured the usual way as a handler ( AddType application/x-httpd-php .php ).
Disable AP2FILTER, recompile, deinstall and reinstall -> WORKS.

Maybe only FreeBSD specific though