Problem mit dem DSGVO/GDPR-Modul Opt-in

dsgvo

#1

Hallo,

ich habe die beiden Module “GDPR base” und “GDPR Opt-in” installiert (Shop-Version CE 4.10.7).

Fast alle Einstellungen führen zu den gewünschten Änderungen im Shop.

Nur “Opt-In für die Benutzerregistrierung” funktioniert nicht. Die Checkbox mit dem Text “Ja ich will…” erscheint nicht, und wenn der neue Kunde versucht, sich anzumelden, kommt die Meldung: “Bitte stimmen Sie dem Speichern der Daten zu!”

Nur wo keine Checkbox ist, kann er auch nicht zustimmen.

Ich habe die beiden Module mehrmals installiert und wieder gelöscht, hat aber nichts gebracht.

Und wie gesagt, der Rest funktioniert ja einwandfrei.

Hat jemand eine Idee?

Vielen Dank schon mal


#2

wurde das Template angepasst? Bei mir ist alles da, direkt unter der Newsletter Checkbox


#3

Hallo,

das Opt-in - Modul fügt die Checkbox an dieser Stelle im Block user_account_newsletter ein.

Wenn man zB. mit einem Modul die Newsletteranmeldung an dieser Stelle entfernt hat (und das Modul das letzte in der Reihenfolge ist), wird auch die Checkbox zur Registrierung entfernt.

Die Position der Registrierung-Checkbox im Standard-Theme und der Umstand, dass ein Newsletter-Block dafür verwendet wird, ist schon etwas seltsam.


#4

Guten Morgen,

ich hatte tatsächlich ein Modul zum Ausblenden des Newsletters installiert (das Modul stammt von Ihnen, Herr Puckl; auf diesem Wege auch einmal vielen Dank für Ihre vielen, nützlichen Module). Wenn ich das abschalte, dann kommt der Text des Opt-In-Moduls und alles ist gut.

Ich will den Newsletter immer noch nicht, muss mir halt jetzt was einfallen lassen, wie ich den weg bekomme.

Vielen Dank für den Tipp, hat mir sehr weitergeholfen.

Schönen Sonntag noch


#5

In der aktuellsten Modul-Version wurde das Problem behoben. :grinning:


#6

Super… vielen Dank.


#7

Ich habe diese Module installiert:
GDPR Opt-in
GDPR Base
AntiNewsletter von ecomstyle
psContactForm

Alles funktioniert - aber gestern hatte ein Kunde bei der Registrierung bemängelt, dass er die UST-ID zwar eingeben kann, aber immer die Meldung “Fehler: Die angegebene Umsatzsteuer-Identnummer konnte nicht verifiziert werden” erscheint.

Ich habe es ebenso heute probiert und tatsächlich erhalte ich auch diese Meldung obwohl die UST-ID stimmt.

Hängt das irgendwie mit den Modulen zusammen?


#8

Der Webdienst für die USt.ID-Prüfung scheint Nachts (manchmal?) nicht zu funktionieren.


#9

Quelle: https://evatr.bff-online.de/eVatR/xmlrpc/

Wichtiger Hinweis:
Über diese Schnittstelle können Sie sich täglich, in der Zeit zwischen 05:00 Uhr und 23:00 Uhr, die Gültigkeit einer ausländischen Umsatzsteuer-Identifikationsnummer (USt-IdNr.) bestätigen lassen. …


#10

Ich weiß nicht, ob dieses Problem seit Installation des GDPR-Modul besteht. Es hat sich heute erst ein Kunde gemeldet, also denke ich, es hat mit dem Update CE 4.10.6 auf CE 4.10.8 zu tun (??)

Aktuell habe die Oxid Version CE 4.10.8

Module (und noch weitere von ecomstyle):
GDPR Opt-in
GDPR Base
AntiNewsletter von ecomstyle (aktuelle Version)
psContactForm

Folgendes Problem:
Kunde ist seit Jahren registriert, hat eine Rechnungsadresse hinterlegt und will nun bei einer neuen Bestellung eine neue Lieferadresse hinzufügen.

Meldung:
Bitte stimmen Sie dem Speichern der Lieferadresse zu!

Problem:
Es erscheint keine Checkbox zum bestätigen.

Kann mir bitte einer von euch helfen?


#11

Da wird wohl da template angepasst sein, so dass die checkbox nicht mehr eingefügt werden kann


#12

Ich habe eigentlich nichts angepaßt.
Nur ein Hintergrundbild eingefügt über Oxid-Admin und nur der Header ist anders.


#13

Ok, ich glaube ich habe es. Ein Zusatzmodul verändert sicherlich dieses Template und harmoniert nicht mit den beiden GDPR Modulen. Deaktiviere ich dieses Zusatzmodul und leere den tmp-Ordner, so erscheint die Checkbox aber die Funktionen des Zusatzmodules funktionieren halt dann nicht (logisch).

Ich habe mal dem Anbieter geschrieben und warte nun auf die Antwort.

Danke vanilla_thunder!


#14

theoretisch, auch wenn das Modul verschlüsselt ist, müsste das mit 1-2 Zeilen Code im Templalte lösbar sein.
Überschreibt das betroffene Modul den Block “user_shipping_address_form” im Template form/user.tpl?


#15

Kann ich leider als “Nicht-Fachmann” nicht sagen.
Im Testshop des Modulanbieters tritt aber exakt das gleiche Problem auf. (Stand 01.09.2018 - 17:00Uhr)

http://oxid4101.aggrosoft.de

  1. Als Kunde registrieren
  2. Waren in den Warenkorb legen
  3. Weiter klicken und dann Lieferadresse wählen.
  4. Checkbox erscheint nicht. Es erscheint nur oben “Bitte stimmen Sie dem Speichern der Lieferadresse zu!”

Also liegt es doch an dem zusätzlichen Modul. Denn wenn ich das Modul deaktiviere, erscheint die Checkbox.


#16

Aktuelle Rückmeldung (03.09.18) des Modulanbieters:
„Ich konnte den Fehler nachvollziehen. Aber das passiert auch dann, wenn das Modul deaktiviert ist. Das ist Oxid Bug.“

(Komischerweise hat es bei mir funktioniert bei Deaktivierung Zusatz-Modul…)

Könnt ihr bitte auch überprüfen? Ohne dieses Zusatzmodul?