Problem with removing digidesk module

I have problem with removing DIGIDesk module: dd_article_availability_reminder.


When I click Yes I have “Maintanance mode” :frowning:

When I want to deactivate it from CLI, I get this:

./vendor/bin/oe-console oe:module:deactivate dd_article_availability_reminder

Result:

I also tried to remove configuration without Deactivation but that was stupid :slight_smile: - after using:

oe:module:uninstall-configuration dd_article_availability_reminder

OXID still throws errors in log files:

[2022-08-12 10:32:04] OXID Logger.ERROR: Module class DigideskMediaSolutions\ArticleReminder\Core\ViewConfig not found. Module ID (module id not availible) ["[object] (OxidEsales\\Eshop\\Core\\Exception\\SystemComponentException(code: 0): Module class DigideskMediaSolutions\\ArticleReminder\\Core\\ViewConfig not found. Module ID (module id not availible) at ...

Is there any other option to remove it?

You can try to install the module again so that the module files are copied into modules-folder and the namespace entries are restored. Then deactivate the module, remove the module via composer remove and then remove the module files as well. In the backend, call up the module list and then check whether the module is gone. If there is still a query about the module because of an invalid module, then confirm the query.

ok, I will try it…

dd_base module is required to work with “ArticleReminder” module?

yes dd_base is required for this module which you download from our website: Basis-Modul | digidesk - media solutions

ok, I did this and now SHOP totally stack… MAINTANANCE MODE on start page and admin… do you have any license? or something?

This is current log:

[12 Aug 11:53:53.936991 2022] [uncaught error] [type E_CORE_ERROR] [file Unknown] [line 0] [code ] [message <br>The encoded file <b>.../source/modules/digidesk/dd_article_availability_reminder/Core/ViewConfig.php</b> has expired.]

I can not even deactivate module:

./vendor/bin/oe-console oe:module:deactivate dd_article_availability_reminder

the same error…

It seems you are using a trial version of the module, which has already expired. In this case, please write to us at the support address with the details of the shop and when you have received the trial version from us.

soo you want to say that… if I want to remove this module I need to get another trial and then remove again?

OK, I wrote again to your support.

The problem is that you have already deleted the files.
A simple way would be to delete the part of the module from the Yaml

var/configuration/shops/1.yaml

nope. I tried also this without success.