Probleme beim Update von ce6.1.2 auf ce6.2.3

Hallo,
ich habe gerade o.g. shop-Update durchgeführt.
Jetzt geht gar nix mehr. in oxdishop.log steht:

[17 Dec 09:56:32.919574 2020] [uncaught error] [type E_ERROR] [file /home/ispman/domains/synthon-chemicals.com/vhosts/shop/oxid/source/bootstrap.php] [line 166] [code ] [message Uncaught Error: Class ‘OxidEsales\Eshop\Core\ConfigFile’ not found in /home/ispman/domains/synthon-chemicals.com/vhosts/shop/oxid/source/bootstrap.php:166
Stack trace:
#0 /home/ispman/domains/synthon-chemicals.com/vhosts/shop/oxid/source/index.php(7): require_once()
#1 {main}
thrown]
[17 Dec 09:56:47.984711 2020] [uncaught error] [type E_ERROR] [file /home/ispman/domains/synthon-chemicals.com/vhosts/shop/oxid/source/bootstrap.php] [line 166] [code ] [message Uncaught Error: Class ‘OxidEsales\Eshop\Core\ConfigFile’ not found in /home/ispman/domains/synthon-chemicals.com/vhosts/shop/oxid/source/bootstrap.php:166
Stack trace:
#0 /home/ispman/domains/synthon-chemicals.com/vhosts/shop/oxid/source/index.php(7): require_once()
#1 /home/ispman/domains/synthon-chemicals.com/vhosts/shop/oxid/source/admin/index.php(11): require_once(’/home/ispman/do…’)
#2 {main}
thrown]

wie kann ich das korrigieren?

Danke für Eure Unterstützung.

Da ist anscheinend beim Update Vorgehen etwas schief gelaufen. Ich würde an Deiner Stelle den Composer Update Befehl wiederholen und vorher das Vendor Verzeichnis löschen.

Zusätzlich scheint deine bootstrap.php nicht auf dem aktuellen Stand in der Version CE 6.1.2 würde ich die Zeile 169 erwarten https://github.com/OXID-eSales/oxideshop_ce/blob/v6.5.2/source/bootstrap.php#L169

und wenn es die bootstrap.php Datei von CE 6.2.3 wäre dann würde ich die Fehlermeldung in Zeile 172 erwarten https://github.com/OXID-eSales/oxideshop_ce/blob/v6.6.0/source/bootstrap.php#L172

Die Fehlermeldung an sich deutet daraufhin, dass das Autoloading von Composer nicht funktioniert bzw. das Vendor Verzeichnis eventuell komplett fehlt.

Danke für die Tipps. Beim Update habe ich “übersehen” (was eigentlich kaum möglich sein sollte, schliesslich war der Kasten fett und rot, der angezeigt hat, dass das Update abgebrochen wurde, weil bei einem Modul keine metadata.php-Datei vorhanden war).
Ich hab das Update nochmal durchgeführt, und dieses Modul ausgelassen, danach ging es weiter und das Update lief korrekt bis zu ende, dadurch wurde auch die bootstrap.php aktualisiert.

Jetzt läuft der Shop wieder…

1 Like