Produktbilder Mobilansicht (Kein Photoswipe)

#1

Hallo liebe Oxid-Gemeinde,

ich bin wieder auf eure hilfreiche Ratschläge angewiesen. :slight_smile:

In der mobilen Ansicht unseres Shops öffnet sich nicht beim Tippen auf ein Bild das Photoswipe-Overlay mit der vergrößerten Ansicht. Das Bild an sich wird geöffnet. Man ist also nicht mehr im Shop sondern auf https://…/produktbild.jpg

In der Desktopansicht klappt alles wunderbar und das Photoswipe-Overlay öffnet sich. Ich finde einfach nicht heraus was unser damaliger Designer da verbockt hat. :neutral_face: Unser Theme ist ein Custom Theme und beruht auf dem Flow Theme.

Anschauungsmaterial: https://decorami.de/Dekoartikel/Dekoschleifen-3-Stueck-Weiss.html
Kleiner Hinweis: Nutzt man die Untersuchen-Funktion der gängigen Desktop-Browser, muss man die Seite erst 1x aktualisieren um den Effekt zu erzeugen.

Hoffe, ihr könnt mir mal wieder aus der Patsche helfen!!

Liebe Grüße!

#2

versuchs mal mit flow-fix von hier:

#3

Der Fix hat mir den Shop komplett zerschossen… ich überschreibe die Fix-Dateien mit den “alten” Backup-Dateien und trotzdem funktioniert er nicht :cold_sweat:

Was soll ich machen?? :frowning:

#4

tmp geleert und browser cache gelöscht?

#5

Ja, beides getan

#6

die Datei out/decorami/src/js/scripts.min.js sieht kaputt aus. Lädst du sie per FTP hoch? Wenn ja, versuch mal den Übertragungsmodus auf Binär umzustellen, ansonsten schau mal, ob sie im Backup auch schon kaputt ist.
Bzw man müsste sie auch aus den ursprünglichen Dateien neu kompilieren können.

#7

Danke für die Hilfe, ich habe jetzt ein komplettes Backup eingeleitet. Danach sollte es wieder laufen.

Ich lade sie per FTP hoch, ja. Falls das Backup nicht fruchtet, dann schaue ich mir deinen Lösungsansatz nochmal genauer an.

#8

Überschreiben ohne Sicherung ist nicht gut. Macht euch daraus doch ein Child-Template Flow-Fix Child-Templ.

#9

Hi rubbercut,

das wäre dann nur zum Testen, ob es prinzipiell bei uns funktioniert oder?

#10

Nicht unbedingt. Wenn euer Template “kein Child” ist, kannst es so lassen, musst aber die Einstellungen in theme.php u.U.anpassen:

‘parentTheme’ => ‘flow’,

‘parentVersions’ => array(‘1.0.0’),

#11

Unser Template ist custom und hat das Flow Template als Parent-Template.

Ich müsste wohl alle Dateien aus dem Fix mit unseren Template-Dateien zusammenführen, damit das ganze klappt. Sehe ich das richtig?

Das steht schon bei uns in der theme.php:

'parentTheme'    =>  'flow',
'parentVersions' =>  array('1.0.0')
#12

Seiht so aus.Es sollte aber trotzdem kein Problem sein, die “alten” Dateien umzubenennen und bei Bedarf wiederherzustellen.

#13

Habe es hinbekommen alle Dateien entsprechend anzupassend und es läuft jetzt super! :slight_smile: Ich bedanke mich wieder ein Mal für die super Hilfe hier im Forum!! :slight_smile: