Richtige Composer Version?

Sollte oder muss man für Oxid eigentlich die aktuellste Version von Composer haben?

Aufgrund eines Fehlers beim Versuch ein Modul (kein selbsterstelltes, es sollte also wirklich funktionieren) über Composer zu installieren frage ich mich nun ob ich Composer aktualisiert kriegen muss (womit ich auch schon fleißig gescheitert bin) oder ob ich evtl ein anderes Problem habe?

[ErrorException}
proc_open(): fork failed - Cannot allocate memory

Oxid CE 6.2.3
Composer 1.10.20
PHP 7.2.24

Inzwischen hab ich doch endlich mal ein Update auf Composer v2 geschafft, leider gibts dann aber nur das hier beim ‘oxid-update’:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - oxid-esales/oxideshop-ide-helper is locked to version v3.1.2 and an update of this package was not requested.
    - oxid-esales/oxideshop-ide-helper v3.1.2 requires composer-plugin-api ^1.1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

heißt das jetzt, dass Composer v2 gar nicht richtig ist für Oxid?

jop, das heißt es.
v1.10 war schon richtg, aber die Fehlermeldung hat nichts mit OXID zu tun.
versuch mal das hier:

1 Like

Nein, alle Versionen kleiner als 6.2.3 benötigen noch Composer Version 1. Erst ab Version 6.2.3 wird Composer Version 2 unterstützt von OXID eShop.

Das bedeutet Du hast nicht genug Zwischenspeicher bei Deinem Hoster um alle Pakete für OXID eShop zu beziehen.

Meine Vermutung ist, dass Du Dev-Packages geladen hast und das Vendor Verzeichnis neu aufbauen müsstet.