SEO URL ignoriert bzw. nicht gespeichert

Ich habe in allen Oxid-Versionen Probleme mit den SEO-URL, jetzt auch in CE 6.0.2. Ein konkretes Beispiel: Ein Produkt ist verschiedenen Kategorien zugeordnet. Eine davon ist eine versteckte Kategorie, die nur zur internen Gruppierung von Produkten gedacht ist. Oxid generiert natürlich ausgerechnet daraus die Haupt-URL für den Artikel, so dass der versteckte Kategorienname in der URL auftaucht.
Aber egal, dafür gibt es ja den Reiter “SEO” im Backend. Also schnell “SEO URL” geändert und gespeichert. Zack, springt die URL wieder auf die vorherige Zeichenkette. Also gut, Haken bei “fixed URL” gesetzt, URL erneut geändert und gespeichert. Und wieder springt die URL auf den vorherigen Inhalt zurück.
Ist das ein Bedienungsfehler von mir? Ein Bug, der sich durch viele Oxid-Versionen zieht?
Nachdem ich hier so einige Foreneinträge gelesen habe: Ich kann mit Sicherheit sagen, dass die neue, gewünschte URL ganz sicher nicht bereits vorhanden ist. Und ich will auch nicht die SEO-Tabelle leeren oder die SEO-URLs alle neu berechnen lassen, weil ich keine funktionierenden URL ändern will, auf die ggf. von extern verlinkt wird (Banner in Affiliate Marketing, Google Ads-Anzeigen etc.)

Wenn jemand Tipps hat, wie man das Problem umgeht (auch für zukünftige Shops, die ich demnächst anlegen möchte), wäre ich echt dankbar.

prüfe mal, welche Kategorie bei diesem Produkt Hauptkategorie hinterlegt ist.

1 Like

Ha! Das ist es! :smile:
Danke für die schnelle Antwort.
Tatsächlich war die ungewünschte Kategorie offenbar automatisch als Hauptkategorie eingestellt. Geändert, und schon stimmt die SEO-URL wieder. Das löst mein Problem elegant!
(Ich frage mich allerdings schon für andere Fälle als meinen, wie man dann individuelle URL einstellen soll, wenn die eingegebene Zeichenkette einfach nicht gespeichert wird)