Setup can't find Mysql module - completely stuck with this

Hello, i am trying to install but i can’t even get past step one in the setup.

The “MySQL module for MySQL 5” is red :mad:

I am running OSX Server (Snow Leopard Server 10.6.2) with php 5.3 and Mysql 5.0.5 installed, setup and running.

All other items are in the green but i just can’t figure out this module thing …

Is this “MySQL module for MySQL 5” something i have to install separately of the already preloaded php/mysql install on OSX server ???

Although i’m not sure it’s related, i enabled php_mysql.dll and php_mysqli.dll in my php.ini file (although i can’t find these dll files anywhere) and i searched the php>extensions folder but couldn’t find any (although again i’m not sure there should be one).

Have spent hours trying to sort this out and also tried this out on another machine with Snow Leopard (not the server version) where i have the same problem.

Thx for any help with this, would love to try out OXID :rolleyes:

Hi chris1249,

although I have no idea from OSX, your phpinfo() shall have an entry for a MySQL client > 5. This means that your PHP installation has to have an extension called php5-mysql.

You might also want to checkout the Debian VMware which is prepared for use as a development environment:


Hi Marco,

thx for taking the time to respond, however it’s quite a strange answer …

Concerning your suggestion to move to Debian VMware … well i’m running a fully funtional server on OSX already so it seems obvious that i’m not going to switch to Windows or Linux …

and as i stated in my initial post: “php 5.3 and Mysql 5.0.5 installed, setup and running.” so i don’t quite understand your comment: “your phpinfo() shall have an entry for a MySQL client > 5”

in any case, i solved the problem with a patch i found in the bugtracker:

in the file


insert these lines:

   //Abschalten der Mysql Überprüfung 
    return 2;


 * Checks if mysql5 extension is loaded.
 * @return integer
public function checkMysqlConnect()

somewhere around line 320.

That lets the test pass, proceed with the iinstal, and everything runs fine after that …

Hi Chris,

I suggested to use the VMware appliance because it provides all system requirements prepared for proper use with the software. It is a virtual machine so I didn’t want you to change your OS :wink:

OXID eShop in the present version 4.2.0 is not ready to run under PHP 5.3 yet. This issue will hopefully be resolved with the upcoming version 4.3.0, to be released soon(ish). If you want to run it anyway you have to expect further problems.

phpinfo() is a PHP function that allows you to see the PHP configuration of your server. In this special case it is interesting to find out whether the php5-mysql client is loaded and if yes - which version. Just write a PHP file named info.php with this content and upload it to your server:

<? phpinfo() ?>

Now, fire up your browser at http://localhost/info.php. Search for the entry MySQL.

in any case, i solved the problem with a patch i found in the bugtracker:

Not good :slight_smile:
With this, you simply annul the system check.


aha … bad news about the php compatibility …

i know what a phpinfo file is :slight_smile: i think we misunderstood each other … what exactly should i be looking for in there ?

Client API version mysqlnd 5.0.5-dev - 081106 - $Revision: $
Client API library version mysqlnd 5.0.5-dev - 081106 - $Revision: $
mysqlnd enabled Version mysqlnd 5.0.5-dev - 081106 - $Revision: $

concerning the Virtual machine, i’d have to buy Vmware (i have parrallels) and would prefer to run this under OSX Server since i already have that setup and running with all my other applications …

Hi Chris,

perhaps it is worth waiting some days until the 4.3.0 is released. I really hope the guys could fix the PHP 5.3.0 compatibility issue.


Hi MArco, i just downladed and wanted to install 4.3.0 and unfortunately i’m still getting orange for the “MySQL Module for MySQL 5” :frowning:

should i hack it again to bypass the php module check ? the previous version seemed to run without problems even though i bypassed the test.

i don’t quite understand this but am not a php expert … php is running/working fine as far as i know (dozens of php/mysql apps running without probs)

just that i understand why does this check fail ? is it because:

1 - it’s just a bug in the installer which doesn’t recognize my php module (maybe because i’m on Mac OSX Server)

2 - i don’t have a MySQL php module (maybe the other php apps don’t need this only oxid)

I think it’s just because of the “dev” (which marks mysqlnd as development-version), so i think it’s ok to bypass the test.


we found the problem and solved it.
It was releated to this bug
With next release 4.3.1 it will be solved.

Regards Stefan