Shop/Admin- Formattierung seit Umstellung auf SSL nicht mehr


#1

Hallo zusammen,

ich bin neu hier und wurde gestern mit einer Aufgabe betraut, die Homepage einer Band DSGVO Konform zu machen.

Nach dem ich die SSL Verschlüsselung aktiviert hatte, funktionierte gar nichts mehr.
Nach etwas “Googeln” stieß ich auf die “config.inc.php” und habe unter …

$this->sSSLShopURL
$this->sAdminSSLURL

… statt = null; die Shop Adresse und die Admin Adresse eingetragen.

Soweit so gut. Nur leider bekomme ich es nicht auf die Reihe, dass der Admin und der Shop Bereich formatiert werden über CSS oder sonstiges…

Was habe ich falsch gemacht?! Ich bin langsam am Verzweifeln…
Vielen Dank vorab für Eure Hilfe.

Viele Grüße
Stefan


#2

ich hab vor lauter euphorie ein paar Eckdaten vergessen.

PHP: 5.6
MySQL: 5.5
Oxid Shop: 4.7.6


#3

Du musst für beide URLs https eintragen, auch für die nicht-SSL-URL und eine http->https Weiterleitung einbauen.
Und Admin ssl URL kannst du wieder auf null stellen, das braucht man hier nicht.


#4

Hallo vanilla_thunder,

vielen Dank für deine schnelle Antwort. Jetzt funktionierts soweit…

Gleich noch eine Frage:
Wo wird im Admin-Menü die Navigation eingestellt? Heisst welche Seiten bzw. Kategorien angezeigt werden sollen?

Wenn du mal auf die Shop-Seite schaust (https://www.stoapfaelzer-spitzbuam.de/shop/), dann ist keine Seite in der Navigation erreichbar. Bei einigen stimmt die URL auch noch nicht?!

Danke!

Viele Grüße


#5

das mit den URL’s hab ich hinbekommen. Ich steh völlig auf dem Schlauch, warum keine Seite erreichbar ist. Wäre sehr dankbar über jede Hilfe…


#6

schau mal in die URLs der unerreichbaren Seiten, da kommt ein /de/ nach der Domain.
Vermutlich wurde der Shop mal auf englisch installiert und später versucht auf Deutsch als Standardsprache umzustellen.
Wie man das jetzt noch beheben kann, weiß ich aber leider nicht.
Ggf. SEO Urls prüfen oder Spracheinstellungen vom Shop


#7

wenn ich eine neue CMS-Seite machen würde und die in die Navigation packe (weiß nur nicht wie das geht), dann muss die Seite doch aufgemacht werden?!


#8

nicht unbedingt. Kaputt ist kaputt, aber kommt darauf an, was kaputt ist


#9

jo, das frag ich mich allerdings auch. Würde eine Neuinstallation des Shops mit neuer Datenbank helfen?


#10

Wenn man es von Anfang an auf Deutsch / für Deutschland installiert, dann auf jeden Fall. Du kannst ja in einem Unterordner probieren und dann das Theme und Module übernehmen.


#11

wie gesagt der Shop lief bis vor zwei Tagen noch einwandfrei. Nur seit der Umstellung durch mich haut gar nichts mehr hin…

Die Dateistruktur sieht so aus /de <- hier liegt die reguläre Page (https://www.stoapfaelzer-spitzbuam.de)
und hier /de/shop <- liegt der shop.

Vorher wars so, dass der shop unter http://www.stoapfaelzer-spitzbuam.de/de/shop erreichbar war. Wenn ich das jedoch einstelle, dann geht wieder gar nichts mehr.
Bei Google site:http://www.stoapfaelzer-spitzbuam.de sieht man schön wie die Dateistruktur war.

Vielleicht liegts auch daran, dass ich die Pfade nicht mehr so einstellen kann bzw. hier was falsch mache?!


#12

also beinhaltet “Umstellung” nicht nur eine Umstellung auf https sondern auch eine URL Änderung, so dass die URLs in den Links praktisch die alten URLs von “vor der Umstellung” sind?


#13

ich sag mal ja!

noch ein Beispiel, dass die Seite an sich funtkioniert ist der Bestellvorgang.
https://www.stoapfaelzer-spitzbuam.de/shop/index.php?cl=details&cnid=3c77c18984a31a4e9a1eeb44ef2b7a27&anid=3bb639d47b0e51660dd234e1b1d1228f&listtype=list&&

Wenn man eine Größe auswählt und dann zur Kasse, haut dieser Vorgang hin…


#14

wurde ggf in den Stammdaten/Sprachen etwas unter “Basis URL” eingetragen?
Die neue URL muss in config.inc.php angepasst werden und RewriteBase in der htaccess Datei.
Prüfe auf jeden Fall mal die SEO Urls der CMS Seiten, einige funktionieren ja.
Und natürlich tmp/ leeren.


#15

ne, unter Stammdaten steht nichts drin.

in der config.inc.php schauts so aus…

die SEO URLS sind alle nicht aktiv. bei agb1 siehts so aus…

ich bin am Verzweifeln…