SMTP Server. Sending email configuration

Hi all,

I would like my Oxid shop send emails automatically to customers.
For this I use the menu Core settings in Admin options.

I would like to use gmail account. Therefore I setup as following:
SMTP Server : smtp.gmail.com
SMTP User : [email protected]
SMTP Password : My gmail account password used with [email protected]

But it doesn’t work:confused:. It don’t send automatic emails when to confirm orders. Why ? Am I forgetting something? should I add or delete something…

Your help would be much appreciate…; Thanks:: :slight_smile:

You should use a mailaccount on your shopdomain. Maybe even sendmail would work?

Gmail thinks someone misuses the account as a relay and denies service, as another server with different url tries to send mails with gmail as sender.

I also have mailaccount in my shopdomain:

details from my provider are:

SMTP-Server: mail.my-shop.com
SMTP-Ports: 25 und 587

How should I complete in core settings? like this?
SMTP Server : mail.my-shop.com
SMTP User : [email protected]
SMTP Password : [email protected] password

I already tried and it did not work!!

Any logs? Maybe logs of the mailserver? Or from Apache?
You can ask your hoster once again about this case.

since oxid 4.3.0 you can select different ports for smtp servers http://wiki.oxidforge.org/Downloads/4.3.0

Usage:
For SSL or TLS encryption, use SMTP Server
(Admin tool -> Master Settings -> Core Settings -> Main)
definition in the following form:
protocol://host:port

e.g.
> ssl://smtp.gmail.com:465
or
> tls://smtp.gmail.com:587

Note: please check your SMTP server’s protocol (eith SSL or TLS)
and enter correct protocol/port combination.

e.g. Google Mail has both services active on different ports
(http://mail.google.com/support/bin/answer.py?hl=en&answer=13287):
Port for TLS/STARTTLS: 587
Port for SSL: 465

ah yes - thanks for the hint!

Did not remember that as I am still using the 4.2 :slight_smile: