Test Environment 4.8.7


I am testing oxid 4.8.7 on my local but I got some error related to DB. Could you please let me know,what could be the issue??

oxConnectionException-oxException (time: 2019-10-11 09:28:14): [0]: Unable to load shop config values from database Stack Trace: #0 /var/www/html/rausch/core/oxconfig.php(331): oxConfig->init() #1 /var/www/html/rausch/core/oxconfig.php(1934): oxConfig->getConfigParam(‘blProductive’) #2 /var/www/html/rausch/core/oxshopcontrol.php(621): oxConfig->isProductiveMode() #3 /var/www/html/rausch/core/oxshopcontrol.php(585): oxShopControl->_getErrorReportingLevel() #4 /var/www/html/rausch/core/oxshopcontrol.php(121): oxShopControl->_runOnce() #5 /var/www/html/rausch/core/oxid.php(40): oxShopControl->start() #6 /var/www/html/rausch/index.php(26): Oxid::run() #7 {main} Connection Adress --> Connection Error -->


Have you installed new shop on you local machine and after installing this problem happens, or are trying to run a shop copy and it basically has never worked on your machine yet?

yes the second one, I am trying to run a shop copy and throwing that error…!!

I checked with DB name, username, password but the details are correct and I renamed the DB name as well. but still I am not getting, why this issue occur?

have you double checked the server ip and ports?
create a test.php file with some basic database connecting stuff and see if your credentials work outside of oxid framework.

yes checked and it is working fine…DB connection is good…oxconfig table also having issue, I reuploaded but still the same error.

Check if the oxconfig table is empty or is missing rows, in particular the row where oxvarname=‘blProductive’.

Hi, there was a issue in oxconfig table. I reuploaded and cleared the tmp folder. Then it started working but there is still partial output. Theme is not correctly loaded and admin page also showing some errors.
such as…
Warning : {oxscript} resource not found: js/libs/chosen/chosen.jquery.min.js in /var/www/html/rausch/core/smarty/plugins/function.oxscript.php on line 104

May be the file is missing or functions may be corrupted. Yet to check. Please advice.

Hey guys, file was missing. I added the files and errors disappeared.

But the other thing is Theme is not reloaded correctly. Following are the errors.

Function ‘isB2B’ does not exist or is not accessible! (oxViewConfig)

#0 /var/www/html/rausch/application/views/somedir_name/zoxid.php(79): oxSuperCfg->__call(‘isB2B’, Array)
#1 /var/www/html/rausch/application/views/somedir_name/zoxid.php(79): oxViewConfig->isB2B()
#2 /var/www/html/rausch/tmp/smarty/124a31d8ac956007132dd4c28b04ecb9^%%4E^4E2^4E2928E7%%minibasket.tpl.php(18): ZoxidTheme_somedir_name->renderPriceValue(‘0,00’)
#3 /var/www/html/rausch/core/smarty/Smarty.class.php(1264): include(’/var/www/html/r…’)
#4 /var/www/html/rausch/core/smarty/plugins/function.oxid_include_dynamic.php(66): Smarty->fetch(‘widget/minibask…’)
#5 /var/www/html/rausch/tmp/smarty/124a31d8ac956007132dd4c28b04ecb9^%%36^366^366ECF91%%page.tpl.php(70): smarty_function_oxid_include_dynamic(Array, Object(Smarty))

as the error says, its missing the function isB2B(). Find the module with this function and activate it, otherwise you have to remove this code from tempaltes

Yes Thank you :slight_smile: ). I did Activated the module and some functions were deprecated. So made the changes and deactivated it for further Upgradation.