Unable to install OXID CE 6.2 on Xampp

Hi,

I am trying to install oxid ce 6.2 version on my local machine which has xampp server. but at 5th step of installation i got execution time error so i increased the execution time in php.ini. Now i am getting the below error.

Error while executing command 'Migration'. Return code: '0'.
The command returns the following message:

Package "ocramius/proxy-manager" is not installed
ERROR: Issue while inserting this SQL statements:

I have checked the ocramius /proxy-manager was installed and all the system requirements are met.
Any idea?

Thanks,
Mik

I even tried installing oxid ce 6.2 on All inkl web server. All the folders installed properly, and when i tried to setup the shop it is giving me the following error.

crbug/1173575, non-JS module files deprecated.
(anonymous)	@	(index):2762

No resource with given URL found

Is OXID CE 6.2 still installable? or depreciated?

Yes Oxid 6.2 is still installable. Of course it is deprecated, because Version 6.4 is out, but 6.2 installs and runs just fine. With xampp i would try to clear everything and try to start over again. On Allinkl the error message seems unrelated, are you shure the url points to the correct directory (/source)?

Hi @leofonic ,

Thank you for your reply, I tried to install the shop from the beginning after deleting everything, but still it showing the same problem. I will try on another system and let you know.

and regarding all inkl. I have double checked and contacted all inkl support as well everything seems okay, and the url is pointing to the correct OXID folder but still it is not working. At error log below is the error:

[02 Feb 14:45:48.671451 2022] [uncaught error] [type E_ERROR] [file /www/htdocs/w00d70/staging/source/bootstrap.php] [line 172] [code ] [message Uncaught Error: Class 'OxidEsales\Eshop\Core\ConfigFile' not found in /www/htdocs/w00d70/staging/source/bootstrap.php:172
Stack trace:
#0 /www/htdocs/w00d70/staging/source/index.php(8): require_once()
#1 /www/htdocs/w00d70/staging/source/oxseo.php(29): require('/www/htdocs/w00...')
#2 {main}
  thrown]

and I have checked it the file is available in the core folder. Do not know where is the issue.

Thanks,
Mik

That error is referenced here: Unified Namespace Generator — OXID eShop developer documentation 6.0.0 documentation
Possibly something went wrong during namespace generation, there are some steps listed in the document to resolve it. (It is not the file which is not found but the class)

With your local install: i could see the error when using composer 1, you can upgrade to v2 with

composer self-update --2

then run

composer update --no-dev

In the shop root directory, set config.inc.php writable and run setup again by opening setup directory in browser.

1 Like

Thank you for the reply @leofonic ,

For local host did i you said but it did not work. So i installed wampp and shop got installed successfully.

Regarding, All inkl web server, The link you shared answers the problem. Thanks you for the help. :grinning:

1 Like