Update auf 6.2.0 -> Can only install one of: symfony/yaml[v3.4.38, v2.8.52]

Hallo zusammen. Nachdem ich endlich mal das Upgrade von 4.10.8 auf 6.1.6 erfolgreich durchgeführt habe, hakt es jetzt leider auf dem Treppchen nach 6.2.0.

Ich habe die composer.json nach Anleitung angepasst uns ein ‘composer update --no-plugins --no-scripts’ ausgeführt. Leider erhalte ich jetzt folgenden Fehler und ahbe keinen Plan wie ich diese Abhängigkeit auflösen soll.

  Problem 1
    - Installation request for oxid-esales/oxideshop-metapackage-pe v6.2.0 -> satisfiable by oxid-esales/oxideshop-metapackage-pe[v6.2.0].
    - incenteev/composer-parameter-handler v2.0.0 requires symfony/yaml ~2.0 -> satisfiable by symfony/yaml[v2.8.52, 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.12, v2.0.13, v2.0.14, v2.0.15, v2.0.16, v2.0.17, v2.0.18, v2.0.19, v2.0.20, v2.0.21, v2.0.22, v2.0.23, v2.0.24, v2.0.25, v2.0.9, v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.33, v2.7.34, v2.7.35, v2.7.36, v2.7.37, v2.7.38, v2.7.39, v2.7.4, v2.7.40, v2.7.41, v2.7.42, v2.7.43, v2.7.44, v2.7.45, v2.7.46, v2.7.47, v2.7.48, v2.7.49, v2.7.5, v2.7.50, v2.7.51, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.26, v2.8.27, v2.8.28, v2.8.29, v2.8.3, v2.8.30, v2.8.31, v2.8.32, v2.8.33, v2.8.34, v2.8.35, v2.8.36, v2.8.37, v2.8.38, v2.8.39, v2.8.4, v2.8.40, v2.8.41, v2.8.42, v2.8.43, v2.8.44, v2.8.45, v2.8.46, v2.8.47, v2.8.48, v2.8.49, v2.8.5, v2.8.50, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - Can only install one of: symfony/yaml[v3.4.38, v2.3.0].
    - Can only install one of: symfony/yaml[v3.4.38, v2.3.1].
.
.
.
    - Can only install one of: symfony/yaml[v3.4.38, v2.2.7].
    - Can only install one of: symfony/yaml[v3.4.38, v2.2.8].
    - Can only install one of: symfony/yaml[v3.4.38, v2.2.9].
    - Can only install one of: symfony/yaml[v3.4.38, v2.8.52].
    - oxid-esales/oxideshop-metapackage-ce v6.2.0 requires symfony/yaml v3.4.38 -> satisfiable by symfony/yaml[v3.4.38].
    - oxid-esales/oxideshop-metapackage-pe v6.2.0 requires oxid-esales/oxideshop-metapackage-ce v6.2.0 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.2.0].
    - Installation request for incenteev/composer-parameter-handler v2.0.0 -> satisfiable by incenteev/composer-parameter-handler[v2.0.0].

Hat jemand eine Idee?

Schönen Sonntag noch.

1 Like

Poste mal den require und require-dev Abschnitt deiner composer.json.

 "require": {
    "oxid-esales/oxideshop-metapackage-pe": "v6.2.0",
    "oxid-esales/azure-theme": "^v1.4.2",
    "tronet/trosofortueberweisung": "^8.0"
  },
  "require-dev": {
    "oxid-esales/testing-library": "^v7.0.1",
    "oxid-esales/coding-standards": "^v3.0.5",
    "incenteev/composer-parameter-handler": "v2.0.0",
    "oxid-esales/oxideshop-ide-helper": "^v3.1.2"
  },

Da sieht man dem Wald vor lauter Bäumen nicht. Fehler gefunden.

Korrekt:

 `   "incenteev/composer-parameter-handler": "^v2.0.0",`

Da fehlte ein kleines “^”.

Ich habe mich schon immer gefragt, mit welcher Tastenkombination man dieses Zeichen schreibt! Ich habe es bisher nur in der Zeichentabelle gefunden. U+02C4

Ist bei mir die Taste unter escape und dann Leertaste.

:thinking: Es ist schon verrückt, wie viele Jahre man nun schon vor der Tastatur hockt aber die Taste ist mir bis jetzt nicht aufgefallen! Danke!

1 Like