Update PayOne-Modul

Hallo zusammen!

Beim Oxid 6.2.2 ist ja die PayOne-Version 1.3.1 dabei. Jetzt hab ich gesehen, dass es da ein Update gab: https://github.com/PAYONE-GmbH/oxid-6/releases . Ein Update per composer scheint jedoch nicht möglich:

- oxid-esales/oxideshop-metapackage-ce v6.2.2 requires payone-gmbh/oxid-6 v1.3.1 -> satisfiable by payone-gmbh/oxid-6[v1.3.1] but these conflict with your requirements or minimum-stability.

Hintergrund ist, dass das Modul aktuell bei uns nicht sauber läuft. Hin und wieder werden keine Bestellungen angelegt, obwohl die Zahlung per Paypal oder Kreditkarte erfolgt ist. Ich hatte gehofft, dass es vielleicht mit der neuen Version besser klappt.

Viele Grüße
Alex

das OXID metapackage hat gezielt die version 1.3.1 angegeben, deswegen wird composer immer versuchen diese eine Version zu installieren.

Deswegen müssen wir composer vorgaukeln, dass eine andere Version dieser gewünschten Version entsprehen würde.
Versuch mal folgende Zeile als Dependency in der composer.json im project root Ordner einzufügen:

"payone-gmbh/oxid-6": "v1.4.0 as v1.3.1",

Hi Marat,

danke Dir für die Hilfe! Das hat prinzipiell funktioniert. Allerdings scheint die Version 1.4 nicht kompatibel zu sein, es gab in der Bestellansicht im Tab “PayOne” einen 500er. Ich hab dann wieder downgegraded.

Viele Grüße

Alex