Von jetzt auf gleich composer Fehler: - doctrine/(dbal 2.12.0 requires php ^7.3 || ^8

Eben noch was installiert. Nun kommt obiger Fehler.

-> your php version (7.2.34) does not satisfy that requirement

Ich habe aber 7.4 installiert. Brauche Hilfe :nauseated_face:

Welche Shopversion? Es gibt prinzipiell bei den meisten Hosting-Providern das Missverständnis, dass die PHP-Version, die man vermeintlich für den Webserver www-data aktiviert, nicht gleichzeitig für die CLI verfügbar ist - dort wird sie jedoch für Composer benötigt. Versuch mal auf der Konsole/im Terminal $ php -v - was spuckt das aus?

Bis vor 3 Stunden war aber alles in Odrnung. ich habe oxid 623 und laut composer php 7.2.34 ?

Jetzt geht der composer-Virus um :blush:
Könnte helfen: Composer Update Shop auf 6.3.0 - symfony/filesystem[v4.4.21] - #2 by rubbercut

Omg. Geht zurĂĽclstellen, wenn es nicht gewht?

sollte so noch laufen.

:grinning_face_with_smiling_eyes:

Geht aber net und ich finde das jetz nicht witzig, weil ich kein bischen Ahnung habe, was ich hier mache :roll_eyes:.

hast du den compser-Aufruf mal mit PHP 7.4 probiert? ( /usr/bin/php74)
Wenn ich dich richtig verstanden habe, ist bei Dir PHP 7.2 aktiv, aber 7.4 auch installiert?
EDIT: Vorsicht bin auch erst am lernen! :wink:

Sorry, @Gerome, das war nur meine Reaktion auf @rubbercut’s Beitrag :wink:

Haha. Alles wieder gut. composer update hat die Fehler beseitigt. Dongeee.

Kein thema . Hauptsache, ich kann weiter machen und muĂź nicht alles neu installieren.

Ich keine Ahnung. Ich kopier nur die Sachen zum eingeben.

Geht mir ähnlich. Bin allerdings so weit, dass ich zunehmend merke, dass man ein Grundverständnis für den Shop schon benötigt.
Wegen der PHP-Version würde ich mal Deinen Hoster fragen. Dort ist es ganz oft so, dass mehrere Installationen nebeneinander liegen. Meist kann man diese über Konfigurationsseiten des Anbieters Projektbezogen (URL-bezogen) einstellen, aber ich habe auch schon erlebt, dass von einer älteren Shopinstallation die Version nicht einfach nur neu eingestellt werden konnte, sondern per composer gesetzt werden musste. Und 7.2 ist von NEU ja auch etwas entfernt.